Sylius PayPal Plugin allows unauthorized access to Credit card form, exposing payer name and not requiring 3DS
CVE-2021-41120GHSA-25fx-mxc2-76g7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sylius/paypal-plugin 1.3.1, 1.2.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist sylius/paypal-plugin
- Affected
- >= 1.0.0, < 1.2.4>= 1.3.0, < 1.3.1
- Fixed in
- 1.3.1, 1.2.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-25fx-mxc2-76g7 lists affected ranges: Packagist sylius/paypal-plugin >=1.0.0 =1.3.0 <1.3.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2021-41120: 1.54% estimated exploitation activity in the next 30 days; percentile 74.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact URL to the payment page done after checkout was created with autoincremented payment id (/pay-with-paypal/{id}) and therefore it was easy to access for anyone, not even the order's customer. The problem was, the Credit card form has prefilled "credit card holder" field with the Customer's first and last name. Additionally, the mentioned form did not require a 3D Secure authentication, as well as did not checked the result of the 3D Secure authentication. Patches The problem has been patched in Sylius/PayPalPlugin 1.2.4 and 1.3.1 Workarounds One can override a syliuspaypalpluginpaywithpaypalform route and change its URL parameters to (for example) {orderToken}/{paymentId}, then override the Sylius\PayPalPlugin\Controller\PayWithPayPalFormAction service, to operate on the payment taken from the repository by these 2 values. It would also require usage of custom repository method. Additionally, one could override the @SyliusPayPalPlugin/payWithPaypal.html.twig template, to add…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-25fx-mxc2-76g7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-41120 Advisory: Sylius PayPal Plugin allows unauthorized access to Credit card form, exposing payer name and not requiring 3DS IDs: CVE-2021-41120, GHSA-25fx-mxc2-76g7 Record: https://patchnext.com/advisories/cve-2021-41120 (revision 1, source checked 26 Oct 2026, 13:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sylius/paypal-plugin 1.3.1, 1.2.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist sylius/paypal-plugin: affected >= 1.0.0, < 1.2.4; >= 1.3.0, < 1.3.1; fixed in 1.3.1, 1.2.4 ## Suggested inspection (read-only) - Packagist sylius/paypal-plugin: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sylius/paypal-plugin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-25fx-mxc2-76g7 (GitHub-reviewed advisory GHSA-25fx-mxc2-76g7 lists affected ranges: Packagist sylius/paypal-plugin >=1.0.0 =1.3.0 <1.3.1) Commands are suggestions: review each one before running it.
Loading voting…