LiveQuery publishes user session tokens in parse-server
CVE-2021-41109GHSA-7pr3-p5fm-8r9x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 4.10.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm parse-server
- Affected
- < 4.10.4
- Fixed in
- 4.10.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7pr3-p5fm-8r9x lists affected ranges: npm parse-server >=0 <4.10.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7pr3-p5fm-8r9x lists affected ranges: npm parse-server >=0 <4.10.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2021-41109: 1.25% estimated exploitation activity in the next 30 days; percentile 69.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact For regular (non-LiveQuery) queries, the session token is removed from the response, but for LiveQuery payloads it is currently not. If a user has a LiveQuery subscription on the Parse.User class, all session tokens created during user sign-ups will be broadcast as part of the LiveQuery payload. Patches Remove session token from LiveQuery payload. Workaround Set user.acl(new Parse.ACL()) in a beforeSave trigger to make the user private already on sign-up.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7pr3-p5fm-8r9x
- Revision 1 · created ·
Published from osv record GHSA-7pr3-p5fm-8r9x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-41109 Advisory: LiveQuery publishes user session tokens in parse-server IDs: CVE-2021-41109, GHSA-7pr3-p5fm-8r9x Record: https://patchnext.com/advisories/cve-2021-41109 (revision 2, source checked 26 Oct 2026, 12:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: parse-server 4.10.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm parse-server: affected < 4.10.4; fixed in 4.10.4 ## Suggested inspection (read-only) - `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on parse-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7pr3-p5fm-8r9x (OSV record GHSA-7pr3-p5fm-8r9x lists affected ranges: npm parse-server >=0 <4.10.4 (fixed)) - Verified: https://github.com/advisories/GHSA-7pr3-p5fm-8r9x (GitHub-reviewed advisory GHSA-7pr3-p5fm-8r9x lists affected ranges: npm parse-server >=0 <4.10.4) Commands are suggestions: review each one before running it.
Loading voting…