Skip to content

← Actionable
Medium, CVSS 5.9

Moby (Docker Engine) Insufficiently restricted permissions on data directory

CVE-2021-41091GHSA-3fwx-pjgw-3558

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/docker/docker 20.10.9; github.com/moby/moby 20.10.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
EPSS
  • CVE-2021-41091: 2.85% estimated exploitation activity in the next 30 days; percentile 86.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A bug was found in Moby (Docker Engine) where the data directory (typically /var/lib/docker) contained subdirectories with insufficiently restricted permissions, allowing otherwise unprivileged Linux users to traverse directory contents and execute programs. When containers included executable programs with extended permission bits (such as setuid), unprivileged Linux users could discover and execute those programs. When the UID of an unprivileged Linux user on the host collided with the file owner or group inside a container, the unprivileged Linux user on the host could discover, read, and modify those files. Patches This bug has been fixed in Moby (Docker Engine) 20.10.9. Users should update to this version as soon as possible. Running containers should be stopped and restarted for the permissions to be fixed. Workarounds Limit access to the host to trusted users. Limit access to host volumes to trusted containers. Credits The Moby project would like to thank Joan Bruguera…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3fwx-pjgw-3558

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-41091

Advisory: Moby (Docker Engine) Insufficiently restricted permissions on data directory
IDs: CVE-2021-41091, GHSA-3fwx-pjgw-3558
Record: https://patchnext.com/advisories/cve-2021-41091 (revision 1, source checked 26 Oct 2026, 15:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/docker/docker 20.10.9; github.com/moby/moby 20.10.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/docker/docker: affected < 20.10.9; fixed in 20.10.9
- Go github.com/moby/moby: affected < 20.10.9; fixed in 20.10.9

## Suggested inspection (read-only)
- Go github.com/docker/docker: check the installed version with your package manager.
- Go github.com/moby/moby: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/docker/docker, github.com/moby/moby.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3fwx-pjgw-3558 (GitHub-reviewed advisory GHSA-3fwx-pjgw-3558 lists affected ranges: Go github.com/moby/moby >=0 =0 <20.10.9)

Commands are suggestions: review each one before running it.

Loading voting…