Elvish vulnerable to remote code execution via the web UI backend
CVE-2021-41088GHSA-fpv6-f8jw-rc3r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/elves/elvish 0.14.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.14.0
- Fixed in
- 0.14.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fpv6-f8jw-rc3r lists affected ranges: Go github.com/elves/elvish >=0 <0.14.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.0 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2021-41088: 0.54% estimated exploitation activity in the next 30 days; percentile 45.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Elvish's backend for the experimental web UI (started by elvish -web) hosts an endpoint that allows executing the code sent from the web UI. The backend does not check the origin of requests correctly. As a result, if the user has the web UI backend open and visits a compromised or malicious website, the website can send arbitrary code to the endpoint in localhost. Patches All Elvish releases since 0.14.0 no longer include the experimental web UI, although it is still possible for the user to build a version from source that includes it. The issue can be patched for previous versions by removing the web UI (found in web, pkg/web or pkg/prog/web, depending on the exact version). Workarounds Do not use the experimental web UI. For more information If you have any questions or comments about this advisory, please email xiaqqaix@gmail.com.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fpv6-f8jw-rc3r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-41088 Advisory: Elvish vulnerable to remote code execution via the web UI backend IDs: CVE-2021-41088, GHSA-fpv6-f8jw-rc3r Record: https://patchnext.com/advisories/cve-2021-41088 (revision 1, source checked 26 Oct 2026, 14:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/elves/elvish 0.14.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/elves/elvish: affected < 0.14.0; fixed in 0.14.0 ## Suggested inspection (read-only) - Go github.com/elves/elvish: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/elves/elvish. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fpv6-f8jw-rc3r (GitHub-reviewed advisory GHSA-fpv6-f8jw-rc3r lists affected ranges: Go github.com/elves/elvish >=0 <0.14.0) Commands are suggestions: review each one before running it.
Loading voting…