OpenStack Neutron Denial of Service vulnerability
CVE-2021-40797GHSA-cpx3-696p-3cw9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (neutron 18.1.1, 17.2.1, 16.4.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI neutron
- Affected
- < 16.4.1>= 17.0.0, < 17.2.1>= 18.0.0, < 18.1.1
- Fixed in
- 18.1.1, 16.4.1, 17.2.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cpx3-696p-3cw9 lists affected ranges: PyPI neutron >=0 =17.0.0 =18.0.0 <18.1.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cpx3-696p-3cw9 lists affected ranges: PyPI neutron >=0 =17.0.0 =18.0.0 <18.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2021-40797: 1.77% estimated exploitation activity in the next 30 days; percentile 78.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue was discovered in the routes middleware in OpenStack Neutron before 16.4.1, 17.x before 17.2.1, and 18.x before 18.1.1. By making API requests involving nonexistent controllers, an authenticated user may cause the API worker to consume increasing amounts of memory, resulting in API performance degradation or denial of service.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-cpx3-696p-3cw9
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-cpx3-696p-3cw9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-40797 Advisory: OpenStack Neutron Denial of Service vulnerability IDs: CVE-2021-40797, GHSA-cpx3-696p-3cw9 Record: https://patchnext.com/advisories/cve-2021-40797 (revision 3, source checked 26 Oct 2026, 13:18 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: neutron 18.1.1, 17.2.1, 16.4.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI neutron: affected < 16.4.1; >= 17.0.0, < 17.2.1; >= 18.0.0, < 18.1.1; fixed in 18.1.1, 16.4.1, 17.2.1 ## Suggested inspection (read-only) - `python -m pip show neutron`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on neutron. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-cpx3-696p-3cw9 (OSV record GHSA-cpx3-696p-3cw9 lists affected ranges: PyPI neutron >=0 =17.0.0 =18.0.0 <18.1.1 (fixed)) - Verified: https://github.com/advisories/GHSA-cpx3-696p-3cw9 (GitHub-reviewed advisory GHSA-cpx3-696p-3cw9 lists affected ranges: PyPI neutron >=0 =17.0.0 =18.0.0 <18.1.1) Commands are suggestions: review each one before running it.
Loading voting…