HTTP header injection in Sonatype Nexus Repository
CVE-2021-40143GHSA-f34x-8pf6-qc9c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.sonatype.nexus:nexus-repository 3.34.0-01), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.sonatype.nexus:nexus-repository
- Affected
- >= 3.0.0, <= 3.33.1-01
- Fixed in
- 3.34.0-01
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f34x-8pf6-qc9c lists affected ranges: Maven org.sonatype.nexus:nexus-repository >=3.0.0 <=3.33.1-01
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
- EPSS
- CVE-2021-40143: 2.32% estimated exploitation activity in the next 30 days; percentile 83.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Sonatype Nexus Repository 3.x through 3.33.1-01 is vulnerable to an HTTP header injection. By sending a crafted HTTP request, a remote attacker may disclose sensitive information or request external resources from a vulnerable instance.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-f34x-8pf6-qc9c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-40143 Advisory: HTTP header injection in Sonatype Nexus Repository IDs: CVE-2021-40143, GHSA-f34x-8pf6-qc9c Record: https://patchnext.com/advisories/cve-2021-40143 (revision 1, source checked 26 Oct 2026, 16:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.sonatype.nexus:nexus-repository 3.34.0-01. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.sonatype.nexus:nexus-repository: affected >= 3.0.0, <= 3.33.1-01; fixed in 3.34.0-01 ## Suggested inspection (read-only) - Maven org.sonatype.nexus:nexus-repository: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.sonatype.nexus:nexus-repository. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-f34x-8pf6-qc9c (GitHub-reviewed advisory GHSA-f34x-8pf6-qc9c lists affected ranges: Maven org.sonatype.nexus:nexus-repository >=3.0.0 <=3.33.1-01) Commands are suggestions: review each one before running it.
Loading voting…