Infinite Loop in Apache James
CVE-2021-40111GHSA-fqgw-6qj5-8hmp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.james:james-server 3.6.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.james:james-server
- Affected
- < 3.6.1
- Fixed in
- 3.6.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fqgw-6qj5-8hmp lists affected ranges: Maven org.apache.james:james-server >=0 <3.6.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2021-40111: 2.19% estimated exploitation activity in the next 30 days; percentile 82.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In Apache James, while fuzzing with Jazzer the IMAP parsing stack, we discover that crafted APPEND and STATUS IMAP command could be used to trigger infinite loops resulting in expensive CPU computations and OutOfMemory exceptions. This can be used for a Denial Of Service attack. The IMAP user needs to be authenticated to exploit this vulnerability. This affected Apache James prior to version 3.6.1. This vulnerability had been patched in Apache James 3.6.1 and higher. We recommend the upgrade.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fqgw-6qj5-8hmp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-40111 Advisory: Infinite Loop in Apache James IDs: CVE-2021-40111, GHSA-fqgw-6qj5-8hmp Record: https://patchnext.com/advisories/cve-2021-40111 (revision 1, source checked 26 Oct 2026, 16:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.james:james-server 3.6.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.james:james-server: affected < 3.6.1; fixed in 3.6.1 ## Suggested inspection (read-only) - Maven org.apache.james:james-server: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.james:james-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fqgw-6qj5-8hmp (GitHub-reviewed advisory GHSA-fqgw-6qj5-8hmp lists affected ranges: Maven org.apache.james:james-server >=0 <3.6.1) Commands are suggestions: review each one before running it.
Loading voting…