Improper Access Control in janeczku/calibre-web
CVE-2021-3987GHSA-fj5v-w2jp-wqvj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (calibreweb 0.6.15), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI calibreweb
- Affected
- < 0.6.15
- Fixed in
- 0.6.15
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-fj5v-w2jp-wqvj lists affected ranges: PyPI calibreweb >=0 <0.6.15 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fj5v-w2jp-wqvj lists affected ranges: PyPI calibreweb >=0 <0.6.15
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2021-3987: 0.35% estimated exploitation activity in the next 30 days; percentile 28.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An improper access control vulnerability exists in janeczku/calibre-web. The affected version allows users without public shelf permissions to create public shelves. The vulnerability is due to the createshelf method in shelf.py not verifying if the user has the necessary permissions to create a public shelf. This issue can lead to unauthorized actions being performed by users.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-fj5v-w2jp-wqvj
- Revision 1 · created ·
Published from osv record GHSA-fj5v-w2jp-wqvj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-3987 Advisory: Improper Access Control in janeczku/calibre-web IDs: CVE-2021-3987, GHSA-fj5v-w2jp-wqvj Record: https://patchnext.com/advisories/cve-2021-3987 (revision 2, source checked 26 Oct 2026, 13:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: calibreweb 0.6.15. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI calibreweb: affected < 0.6.15; fixed in 0.6.15 ## Suggested inspection (read-only) - `python -m pip show calibreweb`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on calibreweb. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-fj5v-w2jp-wqvj (OSV record GHSA-fj5v-w2jp-wqvj lists affected ranges: PyPI calibreweb >=0 <0.6.15 (fixed)) - Verified: https://github.com/advisories/GHSA-fj5v-w2jp-wqvj (GitHub-reviewed advisory GHSA-fj5v-w2jp-wqvj lists affected ranges: PyPI calibreweb >=0 <0.6.15) Commands are suggestions: review each one before running it.
Loading voting…