Skip to content

← Actionable
High, CVSS 7.5

Information exposure in elgg

CVE-2021-3980GHSA-hx6g-q9v2-xh7v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (elgg/elgg 4.0.5, 3.3.23), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist elgg/elgg

    Affected
    < 3.3.23>= 4.0.0, < 4.0.5
    Fixed in
    3.3.23, 4.0.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2021-3980: 1.60% estimated exploitation activity in the next 30 days; percentile 75.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

elgg is vulnerable to Exposure of Private Personal Information to an Unauthorized Actor. Forms in the view namespace 'forms/admin' were not protected by an AdminGatekeeper in case of AJAX requests to 'ajax/form/admin/'.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hx6g-q9v2-xh7v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-3980

Advisory: Information exposure in elgg
IDs: CVE-2021-3980, GHSA-hx6g-q9v2-xh7v
Record: https://patchnext.com/advisories/cve-2021-3980 (revision 1, source checked 26 Oct 2026, 14:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: elgg/elgg 4.0.5, 3.3.23. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist elgg/elgg: affected < 3.3.23; >= 4.0.0, < 4.0.5; fixed in 3.3.23, 4.0.5

## Suggested inspection (read-only)
- Packagist elgg/elgg: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on elgg/elgg.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hx6g-q9v2-xh7v (GitHub-reviewed advisory GHSA-hx6g-q9v2-xh7v lists affected ranges: Packagist elgg/elgg >=0 =4.0.0 <4.0.5)

Commands are suggestions: review each one before running it.

Loading voting…