Cross-site Scripting in snipe/snipe-it
CVE-2021-3961GHSA-c65v-p733-9796
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (snipe/snipe-it 5.3.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist snipe/snipe-it
- Affected
- < 5.3.2
- Fixed in
- 5.3.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c65v-p733-9796 lists affected ranges: Packagist snipe/snipe-it >=0 <5.3.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.0 · CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2021-3961: 0.76% estimated exploitation activity in the next 30 days; percentile 55.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
snipe-it is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-c65v-p733-9796
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-3961 Advisory: Cross-site Scripting in snipe/snipe-it IDs: CVE-2021-3961, GHSA-c65v-p733-9796 Record: https://patchnext.com/advisories/cve-2021-3961 (revision 1, source checked 26 Oct 2026, 14:04 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: snipe/snipe-it 5.3.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist snipe/snipe-it: affected < 5.3.2; fixed in 5.3.2 ## Suggested inspection (read-only) - Packagist snipe/snipe-it: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on snipe/snipe-it. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-c65v-p733-9796 (GitHub-reviewed advisory GHSA-c65v-p733-9796 lists affected ranges: Packagist snipe/snipe-it >=0 <5.3.2) Commands are suggestions: review each one before running it.
Loading voting…