Skip to content

← Actionable
High, CVSS 8.7amended

Apprise vulnerable to regex injection with IFTTT Plugin

CVE-2021-39229GHSA-qhmp-h54x-38qr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (apprise 0.9.5.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI apprise

    Affected
    <= 0.9.4
    Fixed in
    0.9.5.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2021-39229: 1.89% estimated exploitation activity in the next 30 days; percentile 79.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Anyone publicly hosting the Apprise library and granting them access to the IFTTT notification service. Patches Update to Apprise v0.9.5.1 The patch to the problem was performed here. Workarounds Alternatively, if upgrading is not an option, you can safely remove the following file: - apprise/plugins/NotifyIFTTT.py The above will eliminate the ability to use IFTTT, but everything else will work smoothly. For more information If you have any questions or comments about this advisory: Open an issue in Apprise Email me at lead2gold@gmail.com Additional Credit Github would not allow me to additionally credit Rasmus Petersen, but I would like to put that here at the very least - thank you for finding and reporting this issue along with those already credited Additional Notes: - Github would not allow me to add/tag the 2 CWE's this issue is applicable to (only CWE-400). The other is: CWE-730 (placed in the title)

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-qhmp-h54x-38qr

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-qhmp-h54x-38qr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-39229

Advisory: Apprise vulnerable to regex injection with IFTTT Plugin
IDs: CVE-2021-39229, GHSA-qhmp-h54x-38qr
Record: https://patchnext.com/advisories/cve-2021-39229 (revision 3, source checked 26 Oct 2026, 13:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: apprise 0.9.5.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI apprise: affected <= 0.9.4; fixed in 0.9.5.1

## Suggested inspection (read-only)
- `python -m pip show apprise`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on apprise.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qhmp-h54x-38qr (OSV record GHSA-qhmp-h54x-38qr lists affected ranges: PyPI apprise >=0 <0.9.5.1 (fixed))
- Verified: https://github.com/advisories/GHSA-qhmp-h54x-38qr (GitHub-reviewed advisory GHSA-qhmp-h54x-38qr lists affected ranges: PyPI apprise >=0 <=0.9.4)

Commands are suggestions: review each one before running it.

Loading voting…