Skip to content

← Actionable
High, CVSS 8.6

Incorrect Authorization with specially crafted requests

CVE-2021-39206GHSA-cfc2-wjcm-c8fm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/pomerium/pomerium 0.15.1, 0.14.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2021-39206: 1.46% estimated exploitation activity in the next 30 days; percentile 73.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Envoy, which Pomerium is based on, contains two authorization related vulnerabilities: - CVE-2021-32777: incorrectly transform a URL containing a #fragment element, causing a mismatch in path-prefix based authorization decisions. - CVE-2021-32779: incorrectly handle duplicate headers, dropping all but the last. This may lead to incorrect routing or authorization policy decisions. Impact With specially crafted requests, incorrect authorization or routing decisions may be made by Pomerium. Patches Pomerium v0.14.8 and v0.15.1 contain an upgraded envoy binary with these vulnerabilities patched. Workarounds - This issue can only be triggered when using path prefix based policy. Removing any such policies should provide mitigation. References envoy GSA CVE-2021-32777 envoy GSA CVE-2021-32779 envoy announcement For more information If you have any questions or comments about this advisory: Open an issue in pomerium/pomerium Email us at security@pomerium.com

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-cfc2-wjcm-c8fm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-39206

Advisory: Incorrect Authorization with specially crafted requests
IDs: CVE-2021-39206, GHSA-cfc2-wjcm-c8fm
Record: https://patchnext.com/advisories/cve-2021-39206 (revision 1, source checked 26 Oct 2026, 14:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/pomerium/pomerium 0.15.1, 0.14.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/pomerium/pomerium: affected >= 0.11.0, < 0.14.8; >= 0.15.0, <= 0.15.0; fixed in 0.15.1, 0.14.8

## Suggested inspection (read-only)
- Go github.com/pomerium/pomerium: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/pomerium/pomerium.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cfc2-wjcm-c8fm (GitHub-reviewed advisory GHSA-cfc2-wjcm-c8fm lists affected ranges: Go github.com/pomerium/pomerium >=0.11.0 =0.15.0 <=0.15.0)

Commands are suggestions: review each one before running it.

Loading voting…