Unsafe defaults in remark-html
CVE-2021-39199GHSA-9q5w-79cv-947m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (remark-html 14.0.1, 13.0.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm remark-html
- Affected
- < 13.0.2>= 14.0.0, <= 14.0.0
- Fixed in
- 13.0.2, 14.0.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9q5w-79cv-947m lists affected ranges: npm remark-html >=0 =14.0.0 <14.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9q5w-79cv-947m lists affected ranges: npm remark-html >=0 =14.0.0 <=14.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N
- EPSS
- CVE-2021-39199: 1.07% estimated exploitation activity in the next 30 days; percentile 65.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The documentation of remark-html has mentioned that it was safe by default. In practise the default was never safe and had to be opted into. This means arbitrary HTML can be passed through leading to potential XSS attacks. Patches The problem has been patched in 13.0.2 and 14.0.1: remark-html is now safe by default, and the implementation matches the documentation. Workarounds On older affected versions, pass sanitize: true, like so: References n/a For more information If you have any questions or comments about this advisory: Open an issue in remark-html Email us at security@unifiedjs.com
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-9q5w-79cv-947m
- Revision 1 · created ·
Published from osv record GHSA-9q5w-79cv-947m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-39199 Advisory: Unsafe defaults in `remark-html` IDs: CVE-2021-39199, GHSA-9q5w-79cv-947m Record: https://patchnext.com/advisories/cve-2021-39199 (revision 2, source checked 26 Oct 2026, 12:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 10.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: remark-html 14.0.1, 13.0.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm remark-html: affected < 13.0.2; >= 14.0.0, <= 14.0.0; fixed in 13.0.2, 14.0.1 ## Suggested inspection (read-only) - `npm ls remark-html --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on remark-html. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9q5w-79cv-947m (OSV record GHSA-9q5w-79cv-947m lists affected ranges: npm remark-html >=0 =14.0.0 <14.0.1 (fixed)) - Verified: https://github.com/advisories/GHSA-9q5w-79cv-947m (GitHub-reviewed advisory GHSA-9q5w-79cv-947m lists affected ranges: npm remark-html >=0 =14.0.0 <=14.0.0) Commands are suggestions: review each one before running it.
Loading voting…