Skip to content

← Actionable
Medium, CVSS 6.3

Older releases of better_errors open to Cross-Site Request Forgery attack

CVE-2021-39197GHSA-w3j4-76qw-wwjm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (better_errors 2.8.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.3 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2021-39197: 0.64% estimated exploitation activity in the next 30 days; percentile 50.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact bettererrors prior to 2.8.0 did not implement CSRF protection for its internal requests. It also did not enforce the correct "Content-Type" header for these requests, which allowed a cross-origin "simple request" to be made without CORS protection. These together left an application with bettererrors enabled open to cross-origin attacks. As a developer tool, bettererrors documentation strongly recommends addition only to the development bundle group, so this vulnerability should only affect development environments. Please ensure that your project limits bettererrors to the development group (or the non-Rails equivalent). Patches Starting with release 2.8.x, CSRF protection is enforced. It is recommended that you upgrade to the latest release, or minimally to "~ 2.8.3". Workarounds There are no known workarounds to mitigate the risk of using older releases of bettererrors. References - Chris Moberly provided an example attack that uses a now-patched vulnerability of…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-w3j4-76qw-wwjm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-39197

Advisory: Older releases of better_errors open to Cross-Site Request Forgery attack
IDs: CVE-2021-39197, GHSA-w3j4-76qw-wwjm
Record: https://patchnext.com/advisories/cve-2021-39197 (revision 1, source checked 26 Oct 2026, 15:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: better_errors 2.8.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems better_errors: affected < 2.8.0; fixed in 2.8.0

## Suggested inspection (read-only)
- RubyGems better_errors: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on better_errors.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-w3j4-76qw-wwjm (GitHub-reviewed advisory GHSA-w3j4-76qw-wwjm lists affected ranges: RubyGems better_errors >=0 <2.8.0)

Commands are suggestions: review each one before running it.

Loading voting…