Skip to content

← Actionable
Medium, CVSS 6.5amended

Privilege escalation: all users can access Admin-level API keys

CVE-2021-39192GHSA-j5c2-hm46-wp5c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ghost 4.10.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm ghost

    Affected
    >= 4.0.0, < 4.10.0
    Fixed in
    4.10.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2021-39192: 1.02% estimated exploitation activity in the next 30 days; percentile 63.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An error in the implementation of the limits service in 4.0.0 allows all authenticated users (including contributors) to view admin-level API keys via the integrations API endpoint, leading to a privilege escalation vulnerability. Ghost(Pro) has already been patched. Self-hosters are impacted if running Ghost a version between 4.0.0 and 4.9.4. Immediate action should be taken to secure your site - see patches & workarounds below. It is highly recommended to regenerate all API keys after patching or applying the workaround below. Patches Fixed in 4.10.0, all 4.x sites should upgrade as soon as possible. Workarounds - Disable all non-Administrator accounts to prevent API access. For more information If you have any questions or comments about this advisory: email us at security@ghost.org --- Credits: Aden Yap Chuen Zhen, BAE Systems Applied Intelligence (Malaysia)

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-j5c2-hm46-wp5c

  2. Revision 1 · created ·

    Published from osv record GHSA-j5c2-hm46-wp5c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-39192

Advisory: Privilege escalation: all users can access Admin-level API keys
IDs: CVE-2021-39192, GHSA-j5c2-hm46-wp5c
Record: https://patchnext.com/advisories/cve-2021-39192 (revision 2, source checked 26 Oct 2026, 12:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ghost 4.10.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm ghost: affected >= 4.0.0, < 4.10.0; fixed in 4.10.0

## Suggested inspection (read-only)
- `npm ls ghost --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ghost.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-j5c2-hm46-wp5c (OSV record GHSA-j5c2-hm46-wp5c lists affected ranges: npm ghost >=4.0.0 <4.10.0 (fixed))
- Verified: https://github.com/advisories/GHSA-j5c2-hm46-wp5c (GitHub-reviewed advisory GHSA-j5c2-hm46-wp5c lists affected ranges: npm ghost >=4.0.0 <4.10.0)

Commands are suggestions: review each one before running it.

Loading voting…