User impersonation due to incorrect handling of the login JWT
CVE-2021-39177GHSA-h77f-xxx7-4858
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.geysermc:connector 1.4.2-SNAPSHOT), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.geysermc:connector
- Affected
- < 1.4.2-SNAPSHOT
- Fixed in
- 1.4.2-SNAPSHOT
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h77f-xxx7-4858 lists affected ranges: Maven org.geysermc:connector >=0 <1.4.2-SNAPSHOT
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2021-39177: 1.44% estimated exploitation activity in the next 30 days; percentile 73.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact <!--What kind of vulnerability is it? Who is impacted?-- This allows anyone that can connect to the server to forge a LoginPacket with manipulated JWT token allowing impersonation as any Bedrock user. Unless credentials are saved in your configuration, online mode is not affected as users are still required to log in separately. If your credentials are saved, there is no risk of exposing your email or password. Patches <!--Has the problem been patched? What versions should users upgrade to?-- This was patched as part of https://github.com/GeyserMC/Geyser/commit/b9541505af68ac7b7c093206ac7b1ba88957a5a6 and https://github.com/GeyserMC/Geyser/commit/ab2f5b326fe590e09167e8b45b4b165ac06ecd13. if your Geyser version is 1.4.2-SNAPSHOT or later, the issue has been addressed on your build. Workarounds <!--Is there a way for users to fix or remediate the vulnerability without upgrading?-- Geyser strongly recommends updating to fix this issue. If this isn't possible: - Use online mode…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-h77f-xxx7-4858
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-39177 Advisory: User impersonation due to incorrect handling of the login JWT IDs: CVE-2021-39177, GHSA-h77f-xxx7-4858 Record: https://patchnext.com/advisories/cve-2021-39177 (revision 1, source checked 26 Oct 2026, 16:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.geysermc:connector 1.4.2-SNAPSHOT. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.geysermc:connector: affected < 1.4.2-SNAPSHOT; fixed in 1.4.2-SNAPSHOT ## Suggested inspection (read-only) - Maven org.geysermc:connector: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.geysermc:connector. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-h77f-xxx7-4858 (GitHub-reviewed advisory GHSA-h77f-xxx7-4858 lists affected ranges: Maven org.geysermc:connector >=0 <1.4.2-SNAPSHOT) Commands are suggestions: review each one before running it.
Loading voting…