Skip to content

← Actionable
High, CVSS 8.1

Unauthenticated SQL Injection in Cachet

CVE-2021-39165GHSA-79mg-4w23-4fqc

What to do

Vendor response not established. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist cachethq/cachet

    Affected
    <= 2.3.18
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2021-39165: 8.17% estimated exploitation activity in the next 30 days; percentile 94.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact In Cachet versions through 2.3.18, there is a SQL injection which is in the SearchableTrait#scopeSearch(). Attackers without authentication can utilize this vulnerability to exfiltrate sensitive data from the database such as administrator's password and session. Patches The original repository of https://github.com/CachetHQ/Cachet is not active, the stable version 2.3.18 and it's developing 2.4 branch is affected. Update to version 2.5 or later in the https://github.com/fiveai/Cachet fork to fix this vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-79mg-4w23-4fqc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-39165

Advisory: Unauthenticated SQL Injection in Cachet
IDs: CVE-2021-39165, GHSA-79mg-4w23-4fqc
Record: https://patchnext.com/advisories/cve-2021-39165 (revision 1, source checked 26 Oct 2026, 14:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor response not established. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist cachethq/cachet: affected <= 2.3.18

## Suggested inspection (read-only)
- Packagist cachethq/cachet: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on cachethq/cachet.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-79mg-4w23-4fqc (GitHub-reviewed advisory GHSA-79mg-4w23-4fqc lists affected ranges: Packagist cachethq/cachet >=0 <=2.3.18)

Commands are suggestions: review each one before running it.

Loading voting…