Improper authorisation of members discloses room membership to non-members
CVE-2021-39164GHSA-3x4c-pq33-4w3q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (matrix-synapse 1.41.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI matrix-synapse
- Affected
- < 1.41.1
- Fixed in
- 1.41.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3x4c-pq33-4w3q lists affected ranges: PyPI matrix-synapse >=0 <1.41.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3x4c-pq33-4w3q lists affected ranges: PyPI matrix-synapse >=0 <1.41.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.1 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2021-39164: 1.45% estimated exploitation activity in the next 30 days; percentile 73.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Unauthorised users can access the membership (list of members, with their display names) of a room if they know the ID of the room. The vulnerability is limited to rooms with shared history visibility. Furthermore, the unauthorised user must be using an account on a vulnerable homeserver that is in the room. Patches Server administrators should upgrade to 1.41.1 or later. Workarounds Administrators of servers that use a reverse proxy could, with potentially unacceptable loss of functionality, block the following endpoints: /matrix/client/r0/rooms/{roomid}/members with at query parameter /matrix/client/unstable/rooms/{roomid}/members with at query parameter References n/a For more information If you have any questions or comments about this advisory, e-mail us at security@matrix.org.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-3x4c-pq33-4w3q
- Revision 1 · created ·
Published from osv record GHSA-3x4c-pq33-4w3q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-39164 Advisory: Improper authorisation of members discloses room membership to non-members IDs: CVE-2021-39164, GHSA-3x4c-pq33-4w3q Record: https://patchnext.com/advisories/cve-2021-39164 (revision 2, source checked 26 Oct 2026, 13:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: matrix-synapse 1.41.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI matrix-synapse: affected < 1.41.1; fixed in 1.41.1 ## Suggested inspection (read-only) - `python -m pip show matrix-synapse`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on matrix-synapse. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3x4c-pq33-4w3q (OSV record GHSA-3x4c-pq33-4w3q lists affected ranges: PyPI matrix-synapse >=0 <1.41.1 (fixed)) - Verified: https://github.com/advisories/GHSA-3x4c-pq33-4w3q (GitHub-reviewed advisory GHSA-3x4c-pq33-4w3q lists affected ranges: PyPI matrix-synapse >=0 <1.41.1) Commands are suggestions: review each one before running it.
Loading voting…