Adding a private/unlisted room to a community exposes room metadata in an unauthorised manner.
CVE-2021-39163GHSA-jj53-8fmw-f2w2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (matrix-synapse 1.41.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI matrix-synapse
- Affected
- < 1.41.1
- Fixed in
- 1.41.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jj53-8fmw-f2w2 lists affected ranges: PyPI matrix-synapse >=0 <1.41.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jj53-8fmw-f2w2 lists affected ranges: PyPI matrix-synapse >=0 <1.41.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.3 · CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2021-39163: 0.90% estimated exploitation activity in the next 30 days; percentile 59.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Unauthorised users can access the name, avatar, topic and number of members of a room if they know the ID of the room. This vulnerability is limited to homeservers where: - the vulnerable homeserver is in the room; and - untrusted users are permitted to create groups (communities). By default, only homeserver administrators can create groups. However, homeserver administrators can already access this information in the database or using the admin API. As a result, only homeservers where the configuration setting enablegroupcreation has been set to true are impacted. Patches Server administrators should upgrade to 1.41.1 or higher. Workarounds Server administrators can set enablegroupcreation to false in their homeserver configuration (this is the default value) to prevent creation of groups by non-administrators. Administrators that are using a reverse proxy could, with partial loss of group functionality, block the following endpoints: /matrix/client/r0/groups/{groupid}/rooms…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-jj53-8fmw-f2w2
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-jj53-8fmw-f2w2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-39163 Advisory: Adding a private/unlisted room to a community exposes room metadata in an unauthorised manner. IDs: CVE-2021-39163, GHSA-jj53-8fmw-f2w2 Record: https://patchnext.com/advisories/cve-2021-39163 (revision 3, source checked 26 Oct 2026, 13:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: matrix-synapse 1.41.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI matrix-synapse: affected < 1.41.1; fixed in 1.41.1 ## Suggested inspection (read-only) - `python -m pip show matrix-synapse`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on matrix-synapse. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jj53-8fmw-f2w2 (OSV record GHSA-jj53-8fmw-f2w2 lists affected ranges: PyPI matrix-synapse >=0 <1.41.1 (fixed)) - Verified: https://github.com/advisories/GHSA-jj53-8fmw-f2w2 (GitHub-reviewed advisory GHSA-jj53-8fmw-f2w2 lists affected ranges: PyPI matrix-synapse >=0 <1.41.1) Commands are suggestions: review each one before running it.
Loading voting…