Skip to content

← Actionable
Critical, CVSS 9.4amended

remote code execution via git repo provider

CVE-2021-39159GHSA-9jjr-qqfp-ppwx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (binderhub 0.2.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2021-39159: 1.93% estimated exploitation activity in the next 30 days; percentile 80.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A remote code execution vulnerability has been identified in BinderHub, where providing BinderHub with maliciously crafted input could execute code in the BinderHub context, with the potential to egress credentials of the BinderHub deployment, including JupyterHub API tokens, kubernetes service accounts, and docker registry credentials. This may provide the ability to manipulate images and other user created pods in the deployment, with the potential to escalate to the host depending on the underlying kubernetes configuration. Patches Patch below, or on GitHub Workarounds Disable the git repo provider by specifying the BinderHub.repoproviders config, e.g.: References Credit: Jose Carlos Luna Duran (CERN) and Riccardo Castellotti (CERN). For more information If you have any questions or comments about this advisory: Email us at security@ipython.org

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-9jjr-qqfp-ppwx

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-9jjr-qqfp-ppwx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-39159

Advisory: remote code execution via git repo provider
IDs: CVE-2021-39159, GHSA-9jjr-qqfp-ppwx
Record: https://patchnext.com/advisories/cve-2021-39159 (revision 3, source checked 26 Oct 2026, 13:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: binderhub 0.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI binderhub: affected < 0.2.0; fixed in 0.2.0

## Suggested inspection (read-only)
- `python -m pip show binderhub`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on binderhub.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9jjr-qqfp-ppwx (OSV record GHSA-9jjr-qqfp-ppwx lists affected ranges: PyPI binderhub >=0 <0.2.0 (fixed))
- Verified: https://github.com/advisories/GHSA-9jjr-qqfp-ppwx (GitHub-reviewed advisory GHSA-9jjr-qqfp-ppwx lists affected ranges: PyPI binderhub >=0 <0.2.0)

Commands are suggestions: review each one before running it.

Loading voting…