Skip to content

← Actionable
High, CVSS 8.5

XStream is vulnerable to an Arbitrary Code Execution attack

CVE-2021-39153GHSA-2q8x-2p7f-574v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.thoughtworks.xstream:xstream 1.4.18), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.5 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2021-39153: 4.46% estimated exploitation activity in the next 30 days; percentile 91.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The vulnerability may allow a remote attacker to load and execute arbitrary code from a remote host only by manipulating the processed input stream, if using the version out of the box with Java runtime version 14 to 8 or with JavaFX installed. No user is affected, who followed the recommendation to setup XStream's security framework with a whitelist limited to the minimal required types. Patches XStream 1.4.18 uses no longer a blacklist by default, since it cannot be secured for general purpose. Workarounds See workarounds for the different versions covering all CVEs. References See full information about the nature of the vulnerability and the steps to reproduce it in XStream's documentation for CVE-2021-39153. Credits Ceclin and YXXX from the Tencent Security Response Center found and reported the issue to XStream and provided the required information to reproduce it. For more information If you have any questions or comments about this advisory: Open an issue in XStream…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-2q8x-2p7f-574v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-39153

Advisory: XStream is vulnerable to an Arbitrary Code Execution attack
IDs: CVE-2021-39153, GHSA-2q8x-2p7f-574v
Record: https://patchnext.com/advisories/cve-2021-39153 (revision 1, source checked 26 Oct 2026, 16:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: com.thoughtworks.xstream:xstream 1.4.18. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven com.thoughtworks.xstream:xstream: affected < 1.4.18; fixed in 1.4.18

## Suggested inspection (read-only)
- Maven com.thoughtworks.xstream:xstream: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on com.thoughtworks.xstream:xstream.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2q8x-2p7f-574v (GitHub-reviewed advisory GHSA-2q8x-2p7f-574v lists affected ranges: Maven com.thoughtworks.xstream:xstream >=0 <1.4.18)

Commands are suggestions: review each one before running it.

Loading voting…