XStream is vulnerable to a Remote Command Execution attack
CVE-2021-39144GHSA-j9h8-phrw-h4fh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.thoughtworks.xstream:xstream 1.4.18), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.thoughtworks.xstream:xstream
- Affected
- < 1.4.18
- Fixed in
- 1.4.18
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j9h8-phrw-h4fh lists affected ranges: Maven com.thoughtworks.xstream:xstream >=0 <1.4.18
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- CISA Known Exploited Vulnerabilities Catalog
CISA added CVE-2021-39144 to the Known Exploited Vulnerabilities catalog on 2023-03-10.
VerifiedObserved Listed in the CISA KEV JSON feed (dateAdded 2023-03-10).
Severity and exploitation
- Exploitation
- Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
- CVSS
- 8.5 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H/E:H
- EPSS
- CVE-2021-39144: 98.12% estimated exploitation activity in the next 30 days; percentile 99.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The vulnerability may allow a remote attacker has sufficient rights to execute commands of the host only by manipulating the processed input stream. No user is affected, who followed the recommendation to setup XStream's security framework with a whitelist limited to the minimal required types. Patches XStream 1.4.18 uses no longer a blacklist by default, since it cannot be secured for general purpose. Workarounds See workarounds for the different versions covering all CVEs. References See full information about the nature of the vulnerability and the steps to reproduce it in XStream's documentation for CVE-2021-39144. Credits Ceclin and YXXX from the Tencent Security Response Center found and reported the issue to XStream and provided the required information to reproduce it. For more information If you have any questions or comments about this advisory: Open an issue in XStream Email us at XStream Google Group
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j9h8-phrw-h4fh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-39144 Advisory: XStream is vulnerable to a Remote Command Execution attack IDs: CVE-2021-39144, GHSA-j9h8-phrw-h4fh Record: https://patchnext.com/advisories/cve-2021-39144 (revision 1, source checked 26 Oct 2026, 16:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.5) Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog. Vendor response: Vendor fix available; fixed versions by package: com.thoughtworks.xstream:xstream 1.4.18. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.thoughtworks.xstream:xstream: affected < 1.4.18; fixed in 1.4.18 ## Suggested inspection (read-only) - Maven com.thoughtworks.xstream:xstream: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.thoughtworks.xstream:xstream. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j9h8-phrw-h4fh (GitHub-reviewed advisory GHSA-j9h8-phrw-h4fh lists affected ranges: Maven com.thoughtworks.xstream:xstream >=0 <1.4.18) - Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2021-39144 to the Known Exploited Vulnerabilities catalog on 2023-03-10.) Commands are suggestions: review each one before running it.
Loading voting…