parse-server new anonymous user session acts as if it's created with password
CVE-2021-39138GHSA-23r4-5mxp-c7g5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 4.5.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm parse-server
- Affected
- < 4.5.2
- Fixed in
- 4.5.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-23r4-5mxp-c7g5 lists affected ranges: npm parse-server >=0 <4.5.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-23r4-5mxp-c7g5 lists affected ranges: npm parse-server >=0 <4.5.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2021-39138: 0.99% estimated exploitation activity in the next 30 days; percentile 62.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Developers that use the REST API to signup users and also allow users to login anonymously. When an anonymous user is first signed up using REST, the server creates session incorrectly, particularly the authProvider field in Session class under createdWith shows the user logged in creating a password. If a developer later depends on the createdWith field to provide a different level of access between a password user and anonymous user, the server incorrectly classified the session type as being created with a password. The server currently doesn't use createdWith to make decisions on how things work internally, so if a developer isn't using createdWith directly, there's nothing to worry about. The vulnerability only affects users who depend on createdWith by using it directly. Patches Upgrade to version 4.5.1. Workarounds Don't use the createdWith Session field to make decisions if you allow anonymous login. References n/a
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-23r4-5mxp-c7g5
- Revision 1 · created ·
Published from osv record GHSA-23r4-5mxp-c7g5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-39138 Advisory: parse-server new anonymous user session acts as if it's created with password IDs: CVE-2021-39138, GHSA-23r4-5mxp-c7g5 Record: https://patchnext.com/advisories/cve-2021-39138 (revision 2, source checked 26 Oct 2026, 12:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: parse-server 4.5.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm parse-server: affected < 4.5.2; fixed in 4.5.2 ## Suggested inspection (read-only) - `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on parse-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-23r4-5mxp-c7g5 (OSV record GHSA-23r4-5mxp-c7g5 lists affected ranges: npm parse-server >=0 <4.5.2 (fixed)) - Verified: https://github.com/advisories/GHSA-23r4-5mxp-c7g5 (GitHub-reviewed advisory GHSA-23r4-5mxp-c7g5 lists affected ranges: npm parse-server >=0 <4.5.2) Commands are suggestions: review each one before running it.
Loading voting…