Skip to content

← Actionable
High, CVSS 8.7

Cross-site scripting vulnerability in file upload

CVE-2021-39136GHSA-hgjr-632x-qpp3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (baserproject/basercms 4.5.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
EPSS
  • CVE-2021-39136: 0.93% estimated exploitation activity in the next 30 days; percentile 60.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

There is a cross-site scripting vulnerability in file upload on the management system of baserCMS. This is a vulnerability that needs to be addressed when the management system is used by an unspecified number of users. If you are eligible, please update to the new version as soon as possible. Target baserCMS 4.5.1 and earlier versions Vulnerability Execution of malicious JavaScript code may alter the display of the page or leak cookie information. Countermeasures Update to the latest version of baserCMS Please refer to the next page for details. https://basercms.net/security/JVN14134801

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hgjr-632x-qpp3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-39136

Advisory: Cross-site scripting vulnerability in file upload
IDs: CVE-2021-39136, GHSA-hgjr-632x-qpp3
Record: https://patchnext.com/advisories/cve-2021-39136 (revision 1, source checked 26 Oct 2026, 14:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: baserproject/basercms 4.5.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist baserproject/basercms: affected <= 4.5.0; fixed in 4.5.1

## Suggested inspection (read-only)
- Packagist baserproject/basercms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on baserproject/basercms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hgjr-632x-qpp3 (GitHub-reviewed advisory GHSA-hgjr-632x-qpp3 lists affected ranges: Packagist baserproject/basercms >=0 <=4.5.0)

Commands are suggestions: review each one before running it.

Loading voting…