Skip to content

← Actionable
High, CVSS 8.2amended

@npmcli/arborist vulnerable to UNIX Symbolic Link (Symlink) Following

CVE-2021-39134GHSA-2h3h-q99f-3fhc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@npmcli/arborist 2.8.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.2 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
EPSS
  • CVE-2021-39134: 0.59% estimated exploitation activity in the next 30 days; percentile 48.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Arbitrary File Creation, Arbitrary File Overwrite, Arbitrary Code Execution @npmcli/arborist, the library that calculates dependency trees and manages the nodemodules folder hierarchy for the npm command line interface, aims to guarantee that package dependency contracts will be met, and the extraction of package contents will always be performed into the expected folder. This is, in part, accomplished by resolving dependency specifiers defined in package.json manifests for dependencies with a specific name, and nesting folders to resolve conflicting dependencies. When multiple dependencies differ only in the case of their name, Arborist's internal data structure saw them as separate items that could coexist within the same level in the nodemodules hierarchy. However, on case-insensitive file systems (such as macOS and Windows), this is not the case. Combined with a symlink dependency such as file:/some/path, this allowed an attacker to create a situation in which arbitrary…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2h3h-q99f-3fhc

  2. Revision 1 · created ·

    Published from osv record GHSA-2h3h-q99f-3fhc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-39134

Advisory: @npmcli/arborist vulnerable to UNIX Symbolic Link (Symlink) Following
IDs: CVE-2021-39134, GHSA-2h3h-q99f-3fhc
Record: https://patchnext.com/advisories/cve-2021-39134 (revision 2, source checked 26 Oct 2026, 12:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @npmcli/arborist 2.8.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @npmcli/arborist: affected < 2.8.2; fixed in 2.8.2

## Suggested inspection (read-only)
- `npm ls @npmcli/arborist --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @npmcli/arborist.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2h3h-q99f-3fhc (OSV record GHSA-2h3h-q99f-3fhc lists affected ranges: npm @npmcli/arborist >=0 <2.8.2 (fixed))
- Verified: https://github.com/advisories/GHSA-2h3h-q99f-3fhc (GitHub-reviewed advisory GHSA-2h3h-q99f-3fhc lists affected ranges: npm @npmcli/arborist >=0 <2.8.2)

Commands are suggestions: review each one before running it.

Loading voting…