Improper Handling of Unexpected Data Type in ced
CVE-2021-39131GHSA-27wq-qx3q-fxm9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ced 1.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm ced
- Affected
- < 1.0.0
- Fixed in
- 1.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-27wq-qx3q-fxm9 lists affected ranges: npm ced >=0 <1.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-27wq-qx3q-fxm9 lists affected ranges: npm ced >=0 <1.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2021-39131: 1.89% estimated exploitation activity in the next 30 days; percentile 79.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact In ced v0.1.0, passing data types other than Buffer causes the Node.js process to crash. Patches The problem has been patched in ced v1.0.0. You can upgrade from v0.1.0 without any breaking changes. Workarounds Before passing an argument to ced, verify it’s a Buffer using Buffer.isBuffer(obj). CVSS score CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/RL:O/RC:C Base Score: 7.5 (High) Temporal Score: 7.2 (High) Since ced is a library, the scoring is based on the “reasonable worst-case implementation scenario”, namely, accepting data from untrusted sources over a network and passing it directly to ced. Depending on your specific implementation, the vulnerability’s severity in your program may be different. Proof of concept curl --request POST --header "Content-Type: text/plain" --data foo http://localhost:3000 crashes the server. References - https://github.com/sonicdoe/ced/commit/a4d9f10b6bf1cd468d1a5b9a283cdf437f8bb7b3
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-27wq-qx3q-fxm9
- Revision 1 · created ·
Published from osv record GHSA-27wq-qx3q-fxm9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-39131 Advisory: Improper Handling of Unexpected Data Type in ced IDs: CVE-2021-39131, GHSA-27wq-qx3q-fxm9 Record: https://patchnext.com/advisories/cve-2021-39131 (revision 2, source checked 26 Oct 2026, 12:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ced 1.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm ced: affected < 1.0.0; fixed in 1.0.0 ## Suggested inspection (read-only) - `npm ls ced --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ced. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-27wq-qx3q-fxm9 (OSV record GHSA-27wq-qx3q-fxm9 lists affected ranges: npm ced >=0 <1.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-27wq-qx3q-fxm9 (GitHub-reviewed advisory GHSA-27wq-qx3q-fxm9 lists affected ranges: npm ced >=0 <1.0.0) Commands are suggestions: review each one before running it.
Loading voting…