NUL character in ROA causes OctoRPKI to crash
CVE-2021-3910GHSA-5mxh-2qfv-4g7j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/cloudflare/cfrpki 1.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/cloudflare/cfrpki
- Affected
- < 1.4.0
- Fixed in
- 1.4.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5mxh-2qfv-4g7j lists affected ranges: Go github.com/cloudflare/cfrpki >=0 <1.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2021-3910: 1.21% estimated exploitation activity in the next 30 days; percentile 68.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
OctoRPKI crashes when encountering a repository that returns an invalid ROA (just an encoded NUL (\0) character). Patches For more information If you have any questions or comments about this advisory email us at security@cloudflare.com
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5mxh-2qfv-4g7j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-3910 Advisory: NUL character in ROA causes OctoRPKI to crash IDs: CVE-2021-3910, GHSA-5mxh-2qfv-4g7j Record: https://patchnext.com/advisories/cve-2021-3910 (revision 1, source checked 26 Oct 2026, 14:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/cloudflare/cfrpki 1.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/cloudflare/cfrpki: affected < 1.4.0; fixed in 1.4.0 ## Suggested inspection (read-only) - Go github.com/cloudflare/cfrpki: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/cloudflare/cfrpki. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5mxh-2qfv-4g7j (GitHub-reviewed advisory GHSA-5mxh-2qfv-4g7j lists affected ranges: Go github.com/cloudflare/cfrpki >=0 <1.4.0) Commands are suggestions: review each one before running it.
Loading voting…