Cross-Site Scripting in grav
CVE-2021-3904GHSA-5jxc-hmqf-3f73
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (getgrav/grav 1.7.24), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist getgrav/grav
- Affected
- < 1.7.24
- Fixed in
- 1.7.24
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5jxc-hmqf-3f73 lists affected ranges: Packagist getgrav/grav >=0 <1.7.24
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.3 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- EPSS
- CVE-2021-3904: 0.59% estimated exploitation activity in the next 30 days; percentile 48.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
grav prior to version 1.7.24 is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting').
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5jxc-hmqf-3f73
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-3904 Advisory: Cross-Site Scripting in grav IDs: CVE-2021-3904, GHSA-5jxc-hmqf-3f73 Record: https://patchnext.com/advisories/cve-2021-3904 (revision 1, source checked 26 Oct 2026, 14:04 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: getgrav/grav 1.7.24. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist getgrav/grav: affected < 1.7.24; fixed in 1.7.24 ## Suggested inspection (read-only) - Packagist getgrav/grav: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on getgrav/grav. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5jxc-hmqf-3f73 (GitHub-reviewed advisory GHSA-5jxc-hmqf-3f73 lists affected ranges: Packagist getgrav/grav >=0 <1.7.24) Commands are suggestions: review each one before running it.
Loading voting…