Command Injection in Apache James
CVE-2021-38542GHSA-84wg-rgp8-2hg4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.james:james-server 3.6.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.james:james-server
- Affected
- < 3.6.1
- Fixed in
- 3.6.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-84wg-rgp8-2hg4 lists affected ranges: Maven org.apache.james:james-server >=0 <3.6.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2021-38542: 2.35% estimated exploitation activity in the next 30 days; percentile 83.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Apache James prior to release 3.6.1 is vulnerable to a buffering attack relying on the use of the STARTTLS command. This can result in Man-in -the-middle command injection attacks, leading potentially to leakage of sensible information.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-84wg-rgp8-2hg4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-38542 Advisory: Command Injection in Apache James IDs: CVE-2021-38542, GHSA-84wg-rgp8-2hg4 Record: https://patchnext.com/advisories/cve-2021-38542 (revision 1, source checked 26 Oct 2026, 16:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.james:james-server 3.6.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.james:james-server: affected < 3.6.1; fixed in 3.6.1 ## Suggested inspection (read-only) - Maven org.apache.james:james-server: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.james:james-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-84wg-rgp8-2hg4 (GitHub-reviewed advisory GHSA-84wg-rgp8-2hg4 lists affected ranges: Maven org.apache.james:james-server >=0 <3.6.1) Commands are suggestions: review each one before running it.
Loading voting…