Skip to content

← Actionable
Critical, CVSS 9.1

Authentication Bypass in ADOdb/ADOdb

CVE-2021-3850GHSA-65mj-7c86-79jf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (adodb/adodb-php 5.21.4, 5.20.21), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist adodb/adodb-php

    Affected
    <= 5.20.20>= 5.21.0, <= 5.21.3
    Fixed in
    5.20.21, 5.21.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2021-3850: 2.17% estimated exploitation activity in the next 30 days; percentile 82.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An attacker can inject values into a PostgreSQL connection string by providing a parameter surrounded by single quotes. Depending on how the library is used in the client software, this may allow an attacker to bypass the login process, gain access to the server's IP address, etc. Patches The vulnerability is fixed in ADOdb versions 5.20.21 (952de6c4273d9b1e91c2b838044f8c2111150c29) and 5.21.4 or later (b4d5ce70034c5aac3a1d51d317d93c037a0938d2). The simplest patch is to delete line 29 in drivers/adodb-postgres64.inc.php: Workarounds Ensure the parameters passed to ADOConnection::connect() or related functions (nConnect(), pConnect()) are not surrounded by single quotes. Credits Thanks to Emmet Leahy (@meme-lord) of Sorcery Ltd for reporting this vulnerability, and to the huntr team for their support. References - Original issue report https://huntr.dev/bounties/bdf5f216-4499-4225-a737-b28bc6f5801c/ - ADOdb reference issue #793 For more information If you have any questions or…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-65mj-7c86-79jf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-3850

Advisory: Authentication Bypass in ADOdb/ADOdb
IDs: CVE-2021-3850, GHSA-65mj-7c86-79jf
Record: https://patchnext.com/advisories/cve-2021-3850 (revision 1, source checked 26 Oct 2026, 14:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: adodb/adodb-php 5.21.4, 5.20.21. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist adodb/adodb-php: affected <= 5.20.20; >= 5.21.0, <= 5.21.3; fixed in 5.20.21, 5.21.4

## Suggested inspection (read-only)
- Packagist adodb/adodb-php: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on adodb/adodb-php.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-65mj-7c86-79jf (GitHub-reviewed advisory GHSA-65mj-7c86-79jf lists affected ranges: Packagist adodb/adodb-php >=0 =5.21.0 <=5.21.3)

Commands are suggestions: review each one before running it.

Loading voting…