Cross site scripting in sylius/sylius
CVE-2021-3841GHSA-hhvr-2q69-4563
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sylius/sylius 1.11.2, 1.10.11, 1.9.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist sylius/sylius
- Affected
- < 1.9.10>= 1.10.0, < 1.10.11>= 1.11.0, < 1.11.2
- Fixed in
- 1.10.11, 1.11.2, 1.9.10
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hhvr-2q69-4563 lists affected ranges: Packagist sylius/sylius >=0 =1.10.0 =1.11.0 <1.11.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.1 · CVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:L
- EPSS
- CVE-2021-3841: 0.26% estimated exploitation activity in the next 30 days; percentile 17.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
sylius/sylius versions prior to 1.9.10, 1.10.11, and 1.11.2 are vulnerable to stored cross-site scripting (XSS) through SVG files. This vulnerability allows attackers to inject malicious scripts that can be executed in the context of the user's browser.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hhvr-2q69-4563
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-3841 Advisory: Cross site scripting in sylius/sylius IDs: CVE-2021-3841, GHSA-hhvr-2q69-4563 Record: https://patchnext.com/advisories/cve-2021-3841 (revision 1, source checked 26 Oct 2026, 14:28 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sylius/sylius 1.11.2, 1.10.11, 1.9.10. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist sylius/sylius: affected < 1.9.10; >= 1.10.0, < 1.10.11; >= 1.11.0, < 1.11.2; fixed in 1.10.11, 1.11.2, 1.9.10 ## Suggested inspection (read-only) - Packagist sylius/sylius: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sylius/sylius. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hhvr-2q69-4563 (GitHub-reviewed advisory GHSA-hhvr-2q69-4563 lists affected ranges: Packagist sylius/sylius >=0 =1.10.0 =1.11.0 <1.11.2) Commands are suggestions: review each one before running it.
Loading voting…