Skip to content

← Actionable
High, CVSS 8.7amended

Antilles Dependency Confusion Vulnerability

CVE-2021-3840GHSA-hgc3-hp6x-wpgx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (antilles-tools 1.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2021-3840: 2.04% estimated exploitation activity in the next 30 days; percentile 81.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Potential Impact: Remote code execution. Scope of Impact: Open-source project specific. Summary Description: A dependency confusion vulnerability was reported in the Antilles open-source software prior to version 1.0.1 that could allow for remote code execution during installation due to a package listed in requirements.txt not existing in the public package index (PyPi). MITRE classifies this weakness as an Uncontrolled Search Path Element (CWE-427) in which a private package dependency may be replaced by an unauthorized package of the same name published to a well-known public repository such as PyPi. The configuration has been updated to only install components built by Antilles, removing all other public package indexes. Additionally, the antilles-tools dependency has been published to PyPi. Mitigation Strategy for Customers (what you should do to protect yourself): Remove previous versions of Antilles as a precautionary measure and Update to version 1.0.1 or later.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-hgc3-hp6x-wpgx

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-hgc3-hp6x-wpgx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-3840

Advisory: Antilles Dependency Confusion Vulnerability
IDs: CVE-2021-3840, GHSA-hgc3-hp6x-wpgx
Record: https://patchnext.com/advisories/cve-2021-3840 (revision 3, source checked 26 Oct 2026, 13:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: antilles-tools 1.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI antilles-tools: affected < 1.0.1; fixed in 1.0.1

## Suggested inspection (read-only)
- `python -m pip show antilles-tools`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on antilles-tools.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hgc3-hp6x-wpgx (OSV record GHSA-hgc3-hp6x-wpgx lists affected ranges: PyPI antilles-tools >=0 <1.0.1 (fixed))
- Verified: https://github.com/advisories/GHSA-hgc3-hp6x-wpgx (GitHub-reviewed advisory GHSA-hgc3-hp6x-wpgx lists affected ranges: PyPI antilles-tools >=0 <1.0.1)

Commands are suggestions: review each one before running it.

Loading voting…