Command injection in Yamale
CVE-2021-38305GHSA-435p-f82x-mxwm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (yamale 3.0.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI yamale
- Affected
- < 3.0.8
- Fixed in
- 3.0.8
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-435p-f82x-mxwm lists affected ranges: PyPI yamale >=0 <3.0.8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-435p-f82x-mxwm lists affected ranges: PyPI yamale >=0 <3.0.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.5 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2021-38305: 2.49% estimated exploitation activity in the next 30 days; percentile 84.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
23andMe Yamale before 3.0.8 allows remote attackers to execute arbitrary code via a crafted schema file. The schema parser uses eval as part of its processing, and tries to protect from malicious expressions by limiting the builtins that are passed to the eval. When processing the schema, each line is run through Python's eval function to make the validator available. A well-constructed string within the schema rules can execute system commands; thus, by exploiting the vulnerability, an attacker can run arbitrary code on the image that invokes Yamale.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-435p-f82x-mxwm
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-435p-f82x-mxwm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-38305 Advisory: Command injection in Yamale IDs: CVE-2021-38305, GHSA-435p-f82x-mxwm Record: https://patchnext.com/advisories/cve-2021-38305 (revision 3, source checked 26 Oct 2026, 13:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: yamale 3.0.8. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI yamale: affected < 3.0.8; fixed in 3.0.8 ## Suggested inspection (read-only) - `python -m pip show yamale`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on yamale. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-435p-f82x-mxwm (OSV record GHSA-435p-f82x-mxwm lists affected ranges: PyPI yamale >=0 <3.0.8 (fixed)) - Verified: https://github.com/advisories/GHSA-435p-f82x-mxwm (GitHub-reviewed advisory GHSA-435p-f82x-mxwm lists affected ranges: PyPI yamale >=0 <3.0.8) Commands are suggestions: review each one before running it.
Loading voting…