Skip to content

← Actionable
Critical, CVSS 9.8

Incorrect buffer size calculation in iced-x86

CVE-2021-38188GHSA-jjx5-3f36-6927

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (iced-x86 1.11.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io iced-x86

    Affected
    < 1.11.0
    Fixed in
    1.11.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2021-38188: 1.27% estimated exploitation activity in the next 30 days; percentile 69.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An issue was discovered in the iced-x86 crate through 1.10.3 for Rust. In Decoder::new(), slice.getunchecked(slice.length()) is used unsafely.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jjx5-3f36-6927

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-38188

Advisory: Incorrect buffer size calculation in iced-x86
IDs: CVE-2021-38188, GHSA-jjx5-3f36-6927
Record: https://patchnext.com/advisories/cve-2021-38188 (revision 1, source checked 26 Oct 2026, 15:33 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: iced-x86 1.11.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io iced-x86: affected < 1.11.0; fixed in 1.11.0

## Suggested inspection (read-only)
- crates.io iced-x86: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on iced-x86.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jjx5-3f36-6927 (GitHub-reviewed advisory GHSA-jjx5-3f36-6927 lists affected ranges: crates.io iced-x86 >=0 <1.11.0)

Commands are suggestions: review each one before running it.

Loading voting…