Inefficient Regular Expression Complexity in vuelidate
CVE-2021-3794GHSA-vvf2-ppj9-pp49
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@vuelidate/validators 2.0.0-alpha.22), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 2.0.0-alpha.21
- Fixed in
- 2.0.0-alpha.22
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vvf2-ppj9-pp49 lists affected ranges: npm @vuelidate/validators >=0 <2.0.0-alpha.22 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vvf2-ppj9-pp49 lists affected ranges: npm @vuelidate/validators >=0 <=2.0.0-alpha.21
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2021-3794: 1.22% estimated exploitation activity in the next 30 days; percentile 68.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
vuelidate is a simple, lightweight model-based validation for Vue.js 2.x & 3.0. A ReDoS (regular expression denial of service) flaw was found in the @vuelidate/validators package. An attacker that is able to provide crafted input to the url(input) function may cause an application to consume an excessive amount of CPU.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-vvf2-ppj9-pp49
- Revision 1 · created ·
Published from osv record GHSA-vvf2-ppj9-pp49
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-3794 Advisory: Inefficient Regular Expression Complexity in vuelidate IDs: CVE-2021-3794, GHSA-vvf2-ppj9-pp49 Record: https://patchnext.com/advisories/cve-2021-3794 (revision 2, source checked 26 Oct 2026, 12:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @vuelidate/validators 2.0.0-alpha.22. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @vuelidate/validators: affected <= 2.0.0-alpha.21; fixed in 2.0.0-alpha.22 ## Suggested inspection (read-only) - `npm ls @vuelidate/validators --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @vuelidate/validators. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vvf2-ppj9-pp49 (OSV record GHSA-vvf2-ppj9-pp49 lists affected ranges: npm @vuelidate/validators >=0 <2.0.0-alpha.22 (fixed)) - Verified: https://github.com/advisories/GHSA-vvf2-ppj9-pp49 (GitHub-reviewed advisory GHSA-vvf2-ppj9-pp49 lists affected ranges: npm @vuelidate/validators >=0 <=2.0.0-alpha.21) Commands are suggestions: review each one before running it.
Loading voting…