Skip to content

← Actionable
Medium, CVSS 6.1amended

Cross-site Scripting in peertube

CVE-2021-3780GHSA-f2c5-997w-7f5c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (peertube 3.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm peertube

    Affected
    < 3.4.0
    Fixed in
    3.4.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2021-3780: 0.90% estimated exploitation activity in the next 30 days; percentile 59.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

peertube is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting'). It was found that one could upload a SVG image and then send the url of that to other users and when they open the link we can get their complete session keys as the session keys stored in local storage and with Javascript easily can be stolen by attackers.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-f2c5-997w-7f5c

  2. Revision 1 · created ·

    Published from osv record GHSA-f2c5-997w-7f5c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-3780

Advisory: Cross-site Scripting in peertube
IDs: CVE-2021-3780, GHSA-f2c5-997w-7f5c
Record: https://patchnext.com/advisories/cve-2021-3780 (revision 2, source checked 26 Oct 2026, 12:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: peertube 3.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm peertube: affected < 3.4.0; fixed in 3.4.0

## Suggested inspection (read-only)
- `npm ls peertube --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on peertube.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-f2c5-997w-7f5c (OSV record GHSA-f2c5-997w-7f5c lists affected ranges: npm peertube >=0 <3.4.0 (fixed))
- Verified: https://github.com/advisories/GHSA-f2c5-997w-7f5c (GitHub-reviewed advisory GHSA-f2c5-997w-7f5c lists affected ranges: npm peertube >=0 <3.4.0)

Commands are suggestions: review each one before running it.

Loading voting…