Uncaught Exception in jsoup
CVE-2021-37714GHSA-m72m-mhq2-9p6c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jsoup:jsoup 1.14.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jsoup:jsoup
- Affected
- < 1.14.2
- Fixed in
- 1.14.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m72m-mhq2-9p6c lists affected ranges: Maven org.jsoup:jsoup >=0 <1.14.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2021-37714: 6.69% estimated exploitation activity in the next 30 days; percentile 93.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact What kind of vulnerability is it? Who is impacted? Those using jsoup to parse untrusted HTML or XML may be vulnerable to DOS attacks. If the parser is run on user supplied input, an attacker may supply content that causes the parser to get stuck (loop indefinitely until cancelled), to complete more slowly than usual, or to throw an unexpected exception. This effect may support a denial of service attack. Patches Has the problem been patched? What versions should users upgrade to? Users should upgrade to jsoup 1.14.2 Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? Users may rate limit input parsing. Users should limit the size of inputs based on system resources. Users should implement thread watchdogs to cap and timeout parse runtimes.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-m72m-mhq2-9p6c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-37714 Advisory: Uncaught Exception in jsoup IDs: CVE-2021-37714, GHSA-m72m-mhq2-9p6c Record: https://patchnext.com/advisories/cve-2021-37714 (revision 1, source checked 26 Oct 2026, 16:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.jsoup:jsoup 1.14.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jsoup:jsoup: affected < 1.14.2; fixed in 1.14.2 ## Suggested inspection (read-only) - Maven org.jsoup:jsoup: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jsoup:jsoup. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m72m-mhq2-9p6c (GitHub-reviewed advisory GHSA-m72m-mhq2-9p6c lists affected ranges: Maven org.jsoup:jsoup >=0 <1.14.2) Commands are suggestions: review each one before running it.
Loading voting…