Skip to content

← Actionable
High, CVSS 8.2amended

Arbitrary File Creation/Overwrite on Windows via insufficient relative path sanitization

CVE-2021-37713GHSA-5955-9wpr-37jh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tar 6.1.9, 5.0.10, 4.4.18), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm tar

    Affected
    < 4.4.18>= 5.0.0, < 5.0.10>= 6.0.0, < 6.1.9
    Fixed in
    4.4.18, 5.0.10, 6.1.9

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.2 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
EPSS
  • CVE-2021-37713: 1.27% estimated exploitation activity in the next 30 days; percentile 69.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Arbitrary File Creation, Arbitrary File Overwrite, Arbitrary Code Execution node-tar aims to guarantee that any file whose location would be outside of the extraction target directory is not extracted. This is, in part, accomplished by sanitizing absolute paths of entries within the archive, skipping archive entries that contain .. path portions, and resolving the sanitized paths against the extraction target directory. This logic was insufficient on Windows systems when extracting tar files that contained a path that was not an absolute path, but specified a drive letter different from the extraction target, such as C:some\path. If the drive letter does not match the extraction target, for example D:\extraction\dir, then the result of path.resolve(extractionDirectory, entryPath) would resolve against the current working directory on the C: drive, rather than the extraction target directory. Additionally, a .. portion of the path could occur immediately after the drive letter,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-5955-9wpr-37jh

  2. Revision 1 · created ·

    Published from osv record GHSA-5955-9wpr-37jh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-37713

Advisory: Arbitrary File Creation/Overwrite on Windows via insufficient relative path sanitization
IDs: CVE-2021-37713, GHSA-5955-9wpr-37jh
Record: https://patchnext.com/advisories/cve-2021-37713 (revision 2, source checked 26 Oct 2026, 12:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tar 6.1.9, 5.0.10, 4.4.18. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm tar: affected < 4.4.18; >= 5.0.0, < 5.0.10; >= 6.0.0, < 6.1.9; fixed in 4.4.18, 5.0.10, 6.1.9

## Suggested inspection (read-only)
- `npm ls tar --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tar.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5955-9wpr-37jh (OSV record GHSA-5955-9wpr-37jh lists affected ranges: npm tar >=0 =5.0.0 =6.0.0 <6.1.9 (fixed))
- Verified: https://github.com/advisories/GHSA-5955-9wpr-37jh (GitHub-reviewed advisory GHSA-5955-9wpr-37jh lists affected ranges: npm tar >=0 =5.0.0 =6.0.0 <6.1.9)

Commands are suggestions: review each one before running it.

Loading voting…