Arbitrary File Creation/Overwrite via insufficient symlink protection due to directory cache poisoning using symbolic links
CVE-2021-37712GHSA-qq89-hq3f-393p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tar 6.1.9, 5.0.10, 4.4.18), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm tar
- Affected
- >= 5.0.0, < 5.0.10>= 6.0.0, < 6.1.9>= 3.0.0, < 4.4.18
- Fixed in
- 4.4.18, 5.0.10, 6.1.9
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qq89-hq3f-393p lists affected ranges: npm tar >=3.0.0 =5.0.0 =6.0.0 <6.1.9 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qq89-hq3f-393p lists affected ranges: npm tar >=5.0.0 =6.0.0 =3.0.0 <4.4.18
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.2 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
- EPSS
- CVE-2021-37712: 1.86% estimated exploitation activity in the next 30 days; percentile 79.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Arbitrary File Creation, Arbitrary File Overwrite, Arbitrary Code Execution node-tar aims to guarantee that any file whose location would be modified by a symbolic link is not extracted. This is, in part, achieved by ensuring that extracted directories are not symlinks. Additionally, in order to prevent unnecessary stat calls to determine whether a given path is a directory, paths are cached when directories are created. This logic was insufficient when extracting tar files that contained two directories and a symlink with names containing unicode values that normalized to the same value. Additionally, on Windows systems, long path portions would resolve to the same file system entities as their 8.3 "short path" counterparts. A specially crafted tar archive could thus include directories with two forms of the path that resolve to the same file system entity, followed by a symbolic link with a name in the first form, lastly followed by a file using the second form. It led to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-qq89-hq3f-393p
- Revision 1 · created ·
Published from osv record GHSA-qq89-hq3f-393p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-37712 Advisory: Arbitrary File Creation/Overwrite via insufficient symlink protection due to directory cache poisoning using symbolic links IDs: CVE-2021-37712, GHSA-qq89-hq3f-393p Record: https://patchnext.com/advisories/cve-2021-37712 (revision 2, source checked 26 Oct 2026, 12:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tar 6.1.9, 5.0.10, 4.4.18. A vendor fix does not mean a deployment is fixed. ## Affected components - npm tar: affected >= 5.0.0, < 5.0.10; >= 6.0.0, < 6.1.9; >= 3.0.0, < 4.4.18; fixed in 4.4.18, 5.0.10, 6.1.9 ## Suggested inspection (read-only) - `npm ls tar --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tar. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qq89-hq3f-393p (OSV record GHSA-qq89-hq3f-393p lists affected ranges: npm tar >=3.0.0 =5.0.0 =6.0.0 <6.1.9 (fixed)) - Verified: https://github.com/advisories/GHSA-qq89-hq3f-393p (GitHub-reviewed advisory GHSA-qq89-hq3f-393p lists affected ranges: npm tar >=5.0.0 =6.0.0 =3.0.0 <4.4.18) Commands are suggestions: review each one before running it.
Loading voting…