Authenticated server-side request forgery in file upload via URL.
CVE-2021-37711GHSA-gcvv-gq92-x94r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (shopware/core 6.4.3.1; shopware/platform 6.4.3.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist shopware/core
- Affected
- <= 6.4.3.0
- Fixed in
- 6.4.3.1
Packagist shopware/platform
- Affected
- <= 6.4.3.0
- Fixed in
- 6.4.3.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gcvv-gq92-x94r lists affected ranges: Packagist shopware/platform >=0 =0 <=6.4.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2021-37711: 1.06% estimated exploitation activity in the next 30 days; percentile 64.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Authenticated server-side request forgery in file upload via URL. Patches We recommend updating to the current version 6.4.3.1. You can get the update to 6.4.3.1 regularly via the Auto-Updater or directly via the download overview. https://www.shopware.com/en/download/#shopware-6 Workarounds For older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-gcvv-gq92-x94r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-37711 Advisory: Authenticated server-side request forgery in file upload via URL. IDs: CVE-2021-37711, GHSA-gcvv-gq92-x94r Record: https://patchnext.com/advisories/cve-2021-37711 (revision 1, source checked 26 Oct 2026, 14:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: shopware/core 6.4.3.1; shopware/platform 6.4.3.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist shopware/core: affected <= 6.4.3.0; fixed in 6.4.3.1 - Packagist shopware/platform: affected <= 6.4.3.0; fixed in 6.4.3.1 ## Suggested inspection (read-only) - Packagist shopware/core: check the installed version with your package manager. - Packagist shopware/platform: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on shopware/core, shopware/platform. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gcvv-gq92-x94r (GitHub-reviewed advisory GHSA-gcvv-gq92-x94r lists affected ranges: Packagist shopware/platform >=0 =0 <=6.4.3.0) Commands are suggestions: review each one before running it.
Loading voting…