Exposed phpinfo() leadked via documentation files
CVE-2021-37704GHSA-cvh5-p6r6-g2qc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpfastcache/phpfastcache 8.0.7, 7.1.2, 6.1.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist phpfastcache/phpfastcache
- Affected
- < 6.1.5>= 7.0.0, < 7.1.2>= 8.0.0, < 8.0.7
- Fixed in
- 8.0.7, 7.1.2, 6.1.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cvh5-p6r6-g2qc lists affected ranges: Packagist phpfastcache/phpfastcache >=0 =7.0.0 =8.0.0 <8.0.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:L
- EPSS
- CVE-2021-37704: 5.89% estimated exploitation activity in the next 30 days; percentile 93.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The phpinfo() can be exposed if the /vendor is not protected from public access. This is a rare situation today since the vendor directory is often located outside the web directory or protected via server rule (.htaccess, etc). Patches Only the v6, v7 and v8 will be patched respectively in 8.0.7, 7.1.2, 6.1.5. Older versions such as v5, v4 are not longer supported and will NOT be patched. Workarounds Protect the /vendor directory from public access. References The first issue revealing this vulnerability is located here: https://github.com/flextype/flextype/issues/567 V6 fix: https://github.com/PHPSocialNetwork/phpfastcache/pull/815 V7 fix: https://github.com/PHPSocialNetwork/phpfastcache/pull/814 V8 fix: https://github.com/PHPSocialNetwork/phpfastcache/pull/813 For more information If you have any questions or comments about this advisory: Open an issue in our issue tracker Email us at security@geolim4.com
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-cvh5-p6r6-g2qc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-37704 Advisory: Exposed phpinfo() leadked via documentation files IDs: CVE-2021-37704, GHSA-cvh5-p6r6-g2qc Record: https://patchnext.com/advisories/cve-2021-37704 (revision 1, source checked 26 Oct 2026, 14:04 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: phpfastcache/phpfastcache 8.0.7, 7.1.2, 6.1.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist phpfastcache/phpfastcache: affected < 6.1.5; >= 7.0.0, < 7.1.2; >= 8.0.0, < 8.0.7; fixed in 8.0.7, 7.1.2, 6.1.5 ## Suggested inspection (read-only) - Packagist phpfastcache/phpfastcache: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on phpfastcache/phpfastcache. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cvh5-p6r6-g2qc (GitHub-reviewed advisory GHSA-cvh5-p6r6-g2qc lists affected ranges: Packagist phpfastcache/phpfastcache >=0 =7.0.0 =8.0.0 <8.0.7) Commands are suggestions: review each one before running it.
Loading voting…