Clipboard-based DOM-XSS
CVE-2021-37700GHSA-gpfj-4j6g-c4w9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@github/paste-markdown 0.3.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.3.4
- Fixed in
- 0.3.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-gpfj-4j6g-c4w9 lists affected ranges: npm @github/paste-markdown >=0 <0.3.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gpfj-4j6g-c4w9 lists affected ranges: npm @github/paste-markdown >=0 <0.3.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
- EPSS
- CVE-2021-37700: 1.66% estimated exploitation activity in the next 30 days; percentile 76.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A self Cross-Site Scripting vulnerability exists in the @github/paste-markdown library. If the clipboard data contains the string <table, a div is dynamically created, and the clipboard content is copied into its innerHTML property without any sanitization, resulting in improper execution of JavaScript in the browser of the victim (the user who pasted the code). Users directed to copy text from a malicious website and paste it into pages that utilize this library are affected. The following @github/paste-markdown code snippet is triggered when the user pastes something and the browser's clipboard data contains an entry whose content-type is text/HTML. Patches A security patch was released in version 0.3.4. Workarounds A Content Security Policy that prevents unsafe-inline helps reduce the likelihood of this vulnerability being exploited in modern browsers. <!-- References Are there any links users can visit to find out more? For more information If you have any questions or…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-gpfj-4j6g-c4w9
- Revision 1 · created ·
Published from osv record GHSA-gpfj-4j6g-c4w9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-37700 Advisory: Clipboard-based DOM-XSS IDs: CVE-2021-37700, GHSA-gpfj-4j6g-c4w9 Record: https://patchnext.com/advisories/cve-2021-37700 (revision 2, source checked 26 Oct 2026, 12:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @github/paste-markdown 0.3.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @github/paste-markdown: affected < 0.3.4; fixed in 0.3.4 ## Suggested inspection (read-only) - `npm ls @github/paste-markdown --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @github/paste-markdown. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-gpfj-4j6g-c4w9 (OSV record GHSA-gpfj-4j6g-c4w9 lists affected ranges: npm @github/paste-markdown >=0 <0.3.4 (fixed)) - Verified: https://github.com/advisories/GHSA-gpfj-4j6g-c4w9 (GitHub-reviewed advisory GHSA-gpfj-4j6g-c4w9 lists affected ranges: npm @github/paste-markdown >=0 <0.3.4) Commands are suggestions: review each one before running it.
Loading voting…