Open Redirect in Next.js
CVE-2021-37699GHSA-vxf5-wxwp-m7g9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (next 11.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm next
- Affected
- >= 0.9.9, < 11.1.0
- Fixed in
- 11.1.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vxf5-wxwp-m7g9 lists affected ranges: npm next >=0.9.9 <11.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vxf5-wxwp-m7g9 lists affected ranges: npm next >=0.9.9 <11.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:N
- EPSS
- CVE-2021-37699: 1.03% estimated exploitation activity in the next 30 days; percentile 63.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Next.js is an open source website development framework to be used with the React library. In affected versions specially encoded paths could be used when pages/error.js was statically generated, allowing an open redirect to occur to an external site. In general, this redirect does not directly harm users although it can allow for phishing attacks by redirecting to an attacker's domain from a trusted domain. Impact - Affected: Users of Next.js between 10.0.5 and 10.2.0 - Affected: Users of Next.js between 11.0.0 and 11.0.1 using pages/error.js without getInitialProps - Affected: Users of Next.js between 11.0.0 and 11.0.1 using pages/error.js and next export - Not affected: Deployments on Vercel (vercel.com) are not affected - Not affected: Deployments with pages/404.js - Note that versions prior to 0.9.9 package next npm package hosted a different utility (0.4.1 being the latest version of that codebase), and this advisory does not apply to those versions. We recommend upgrading to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-vxf5-wxwp-m7g9
- Revision 1 · created ·
Published from osv record GHSA-vxf5-wxwp-m7g9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-37699 Advisory: Open Redirect in Next.js IDs: CVE-2021-37699, GHSA-vxf5-wxwp-m7g9 Record: https://patchnext.com/advisories/cve-2021-37699 (revision 2, source checked 26 Oct 2026, 12:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: next 11.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm next: affected >= 0.9.9, < 11.1.0; fixed in 11.1.0 ## Suggested inspection (read-only) - `npm ls next --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on next. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vxf5-wxwp-m7g9 (OSV record GHSA-vxf5-wxwp-m7g9 lists affected ranges: npm next >=0.9.9 <11.1.0 (fixed)) - Verified: https://github.com/advisories/GHSA-vxf5-wxwp-m7g9 (GitHub-reviewed advisory GHSA-vxf5-wxwp-m7g9 lists affected ranges: npm next >=0.9.9 <11.1.0) Commands are suggestions: review each one before running it.
Loading voting…