Skip to content

← Actionable
Medium, CVSS 6.8amended

Infinite loop in TFLite

CVE-2021-37686GHSA-mhhc-q96p-mfm9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tensorflow 2.6.0rc2; tensorflow-gpu 2.6.0rc2; tensorflow-cpu 2.6.0rc2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI tensorflow

    Affected
    >= 2.6.0rc0, < 2.6.0rc2
    Fixed in
    2.6.0rc2
  • PyPI tensorflow-gpu

    Affected
    >= 2.6.0rc0, < 2.6.0rc2
    Fixed in
    2.6.0rc2
  • PyPI tensorflow-cpu

    Affected
    >= 2.6.0rc0, < 2.6.0rc2
    Fixed in
    2.6.0rc2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.8 · CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2021-37686: 0.17% estimated exploitation activity in the next 30 days; percentile 6.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The strided slice implementation in TFLite has a logic bug which can allow an attacker to trigger an infinite loop. This arises from newly introduced support for ellipsis in axis definition: An attacker can craft a model such that ellipsisendidx is smaller than i (e.g., always negative). In this case, the inner loop does not increase i and the continue statement causes execution to skip over the preincrement at the end of the outer loop. Patches We have patched the issue in GitHub commit dfa22b348b70bb89d6d6ec0ff53973bacb4f4695. The fix will be included in TensorFlow 2.6.0. This is the only affected version. For more information Please consult our security guide for more information regarding the security model and how to contact us with issues and questions. Attribution This vulnerability has been reported by members of the Aivul Team from Qihoo 360.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-mhhc-q96p-mfm9

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-mhhc-q96p-mfm9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-37686

Advisory: Infinite loop in TFLite
IDs: CVE-2021-37686, GHSA-mhhc-q96p-mfm9
Record: https://patchnext.com/advisories/cve-2021-37686 (revision 3, source checked 26 Oct 2026, 13:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tensorflow 2.6.0rc2; tensorflow-gpu 2.6.0rc2; tensorflow-cpu 2.6.0rc2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI tensorflow: affected >= 2.6.0rc0, < 2.6.0rc2; fixed in 2.6.0rc2
- PyPI tensorflow-gpu: affected >= 2.6.0rc0, < 2.6.0rc2; fixed in 2.6.0rc2
- PyPI tensorflow-cpu: affected >= 2.6.0rc0, < 2.6.0rc2; fixed in 2.6.0rc2

## Suggested inspection (read-only)
- `python -m pip show tensorflow`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show tensorflow-gpu`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show tensorflow-cpu`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tensorflow, tensorflow-gpu, tensorflow-cpu.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mhhc-q96p-mfm9 (OSV record GHSA-mhhc-q96p-mfm9 lists affected ranges: PyPI tensorflow >=2.6.0rc0 =2.6.0rc0 =2.6.0rc0 <2.6.0rc2 (fixed))
- Verified: https://github.com/advisories/GHSA-mhhc-q96p-mfm9 (GitHub-reviewed advisory GHSA-mhhc-q96p-mfm9 lists affected ranges: PyPI tensorflow >=2.6.0rc0 =2.6.0rc0 =2.6.0rc0 <2.6.0rc2)

Commands are suggestions: review each one before running it.

Loading voting…