Reference binding to nullptr in boosted trees
CVE-2021-37662GHSA-f5cx-5wr3-5qrc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tensorflow 2.5.1, 2.4.3, 2.3.4; tensorflow-gpu 2.5.1, 2.4.3, 2.3.4; tensorflow-cpu 2.5.1, 2.4.3, 2.3.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI tensorflow
- Affected
- < 2.3.4>= 2.4.0, < 2.4.3>= 2.5.0, <= 2.5.0
- Fixed in
- 2.3.4, 2.4.3, 2.5.1
PyPI tensorflow-gpu
- Affected
- < 2.3.4>= 2.4.0, < 2.4.3>= 2.5.0, <= 2.5.0
- Fixed in
- 2.3.4, 2.4.3, 2.5.1
PyPI tensorflow-cpu
- Affected
- < 2.3.4>= 2.4.0, < 2.4.3>= 2.5.0, <= 2.5.0
- Fixed in
- 2.3.4, 2.4.3, 2.5.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-f5cx-5wr3-5qrc lists affected ranges: PyPI tensorflow >=0 =2.4.0 =2.5.0 =0 =2.4.0 =2.5.0 =0 =2.4.0 =2.5.0 <2.5.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f5cx-5wr3-5qrc lists affected ranges: PyPI tensorflow >=0 =2.4.0 =2.5.0 =0 =2.4.0 =2.5.0 =0 =2.4.0 =2.5.0 <=2.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2021-37662: 0.19% estimated exploitation activity in the next 30 days; percentile 8.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An attacker can generate undefined behavior via a reference binding to nullptr in BoostedTreesCalculateBestGainsPerFeature: A similar attack can occur in BoostedTreesCalculateBestFeatureSplitV2: The implementation does not validate the input values. Patches We have patched the issue in GitHub commit 9c87c32c710d0b5b53dc6fd3bfde4046e1f7a5ad and in commit. 429f009d2b2c09028647dd4bb7b3f6f414bbaad7. The fix will be included in TensorFlow 2.6.0. We will also cherrypick this commit on TensorFlow 2.5.1, TensorFlow 2.4.3, and TensorFlow 2.3.4, as these are also affected and still in supported range. For more information Please consult our security guide for more information regarding the security model and how to contact us with issues and questions. Attribution This vulnerability has been reported by members of the Aivul Team from Qihoo 360.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-f5cx-5wr3-5qrc
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-f5cx-5wr3-5qrc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-37662 Advisory: Reference binding to nullptr in boosted trees IDs: CVE-2021-37662, GHSA-f5cx-5wr3-5qrc Record: https://patchnext.com/advisories/cve-2021-37662 (revision 3, source checked 26 Oct 2026, 13:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tensorflow 2.5.1, 2.4.3, 2.3.4; tensorflow-gpu 2.5.1, 2.4.3, 2.3.4; tensorflow-cpu 2.5.1, 2.4.3, 2.3.4. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI tensorflow: affected < 2.3.4; >= 2.4.0, < 2.4.3; >= 2.5.0, <= 2.5.0; fixed in 2.3.4, 2.4.3, 2.5.1 - PyPI tensorflow-gpu: affected < 2.3.4; >= 2.4.0, < 2.4.3; >= 2.5.0, <= 2.5.0; fixed in 2.3.4, 2.4.3, 2.5.1 - PyPI tensorflow-cpu: affected < 2.3.4; >= 2.4.0, < 2.4.3; >= 2.5.0, <= 2.5.0; fixed in 2.3.4, 2.4.3, 2.5.1 ## Suggested inspection (read-only) - `python -m pip show tensorflow`: prints the installed version. Run with the environment that serves production active. - `python -m pip show tensorflow-gpu`: prints the installed version. Run with the environment that serves production active. - `python -m pip show tensorflow-cpu`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tensorflow, tensorflow-gpu, tensorflow-cpu. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-f5cx-5wr3-5qrc (OSV record GHSA-f5cx-5wr3-5qrc lists affected ranges: PyPI tensorflow >=0 =2.4.0 =2.5.0 =0 =2.4.0 =2.5.0 =0 =2.4.0 =2.5.0 <2.5.1 (fixed)) - Verified: https://github.com/advisories/GHSA-f5cx-5wr3-5qrc (GitHub-reviewed advisory GHSA-f5cx-5wr3-5qrc lists affected ranges: PyPI tensorflow >=0 =2.4.0 =2.5.0 =0 =2.4.0 =2.5.0 =0 =2.4.0 =2.5.0 <=2.5.0) Commands are suggestions: review each one before running it.
Loading voting…