Skip to content

← Actionable
High, CVSS 7.0amended

Null pointer dereference in SparseTensorSliceDataset

CVE-2021-37647GHSA-c5x2-p679-95wc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tensorflow 2.5.1, 2.4.3, 2.3.4; tensorflow-gpu 2.5.1, 2.4.3, 2.3.4; tensorflow-cpu 2.5.1, 2.4.3, 2.3.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI tensorflow

    Affected
    < 2.3.4>= 2.4.0, < 2.4.3>= 2.5.0, <= 2.5.0
    Fixed in
    2.3.4, 2.4.3, 2.5.1
  • PyPI tensorflow-gpu

    Affected
    < 2.3.4>= 2.4.0, < 2.4.3>= 2.5.0, <= 2.5.0
    Fixed in
    2.3.4, 2.4.3, 2.5.1
  • PyPI tensorflow-cpu

    Affected
    < 2.3.4>= 2.4.0, < 2.4.3>= 2.5.0, <= 2.5.0
    Fixed in
    2.3.4, 2.4.3, 2.5.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.0 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2021-37647: 0.16% estimated exploitation activity in the next 30 days; percentile 5.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When a user does not supply arguments that determine a valid sparse tensor, tf.rawops.SparseTensorSliceDataset implementation can be made to dereference a null pointer: The implementation has some argument validation but fails to consider the case when either indices or values are provided for an empty sparse tensor when the other is not. If indices is empty (as in the example above), then code that performs validation (i.e., checking that the indices are monotonically increasing) results in a null pointer dereference: If indices as provided by the user is empty, then indices in the C++ code above is backed by an empty std::vector, hence calling indices-dimsize(0) results in null pointer dereferencing (same as calling std::vector::at() on an empty vector). Patches We have patched the issue in GitHub commit 02cc160e29d20631de3859c6653184e3f876b9d7. The fix will be included in TensorFlow 2.6.0. We will also cherrypick this commit on TensorFlow 2.5.1, TensorFlow 2.4.3, and…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-c5x2-p679-95wc

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-c5x2-p679-95wc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-37647

Advisory: Null pointer dereference in `SparseTensorSliceDataset`
IDs: CVE-2021-37647, GHSA-c5x2-p679-95wc
Record: https://patchnext.com/advisories/cve-2021-37647 (revision 3, source checked 26 Oct 2026, 13:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tensorflow 2.5.1, 2.4.3, 2.3.4; tensorflow-gpu 2.5.1, 2.4.3, 2.3.4; tensorflow-cpu 2.5.1, 2.4.3, 2.3.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI tensorflow: affected < 2.3.4; >= 2.4.0, < 2.4.3; >= 2.5.0, <= 2.5.0; fixed in 2.3.4, 2.4.3, 2.5.1
- PyPI tensorflow-gpu: affected < 2.3.4; >= 2.4.0, < 2.4.3; >= 2.5.0, <= 2.5.0; fixed in 2.3.4, 2.4.3, 2.5.1
- PyPI tensorflow-cpu: affected < 2.3.4; >= 2.4.0, < 2.4.3; >= 2.5.0, <= 2.5.0; fixed in 2.3.4, 2.4.3, 2.5.1

## Suggested inspection (read-only)
- `python -m pip show tensorflow`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show tensorflow-gpu`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show tensorflow-cpu`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tensorflow, tensorflow-gpu, tensorflow-cpu.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-c5x2-p679-95wc (OSV record GHSA-c5x2-p679-95wc lists affected ranges: PyPI tensorflow >=0 =2.4.0 =2.5.0 =0 =2.4.0 =2.5.0 =0 =2.4.0 =2.5.0 <2.5.1 (fixed))
- Verified: https://github.com/advisories/GHSA-c5x2-p679-95wc (GitHub-reviewed advisory GHSA-c5x2-p679-95wc lists affected ranges: PyPI tensorflow >=0 =2.4.0 =2.5.0 =0 =2.4.0 =2.5.0 =0 =2.4.0 =2.5.0 <=2.5.0)

Commands are suggestions: review each one before running it.

Loading voting…