Skip to content

← Actionable
High, CVSS 8.6amended

Null pointer dereference and heap OOB read in operations restoring tensors

CVE-2021-37639GHSA-gh6x-4whr-2qv4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tensorflow 2.5.1, 2.4.3, 2.3.4; tensorflow-gpu 2.5.1, 2.4.3, 2.3.4; tensorflow-cpu 2.5.1, 2.4.3, 2.3.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI tensorflow

    Affected
    < 2.3.4>= 2.4.0, < 2.4.3>= 2.5.0, <= 2.5.0
    Fixed in
    2.3.4, 2.4.3, 2.5.1
  • PyPI tensorflow-gpu

    Affected
    < 2.3.4>= 2.4.0, < 2.4.3>= 2.5.0, <= 2.5.0
    Fixed in
    2.3.4, 2.4.3, 2.5.1
  • PyPI tensorflow-cpu

    Affected
    < 2.3.4>= 2.4.0, < 2.4.3>= 2.5.0, <= 2.5.0
    Fixed in
    2.3.4, 2.4.3, 2.5.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.6 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2021-37639: 0.17% estimated exploitation activity in the next 30 days; percentile 6.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When restoring tensors via raw APIs, if the tensor name is not provided, TensorFlow can be tricked into dereferencing a null pointer: The same undefined behavior can be triggered by tf.rawops.RestoreSlice: Alternatively, attackers can read memory outside the bounds of heap allocated data by providing some tensor names but not enough for a successful restoration: The implementation retrieves the tensor list corresponding to the tensorname user controlled input and immediately retrieves the tensor at the restoration index (controlled via preferredshard argument). This occurs without validating that the provided list has enough values. If the list is empty this results in dereferencing a null pointer (undefined behavior). If, however, the list has some elements, if the restoration index is outside the bounds this results in heap OOB read. Patches We have patched the issue in GitHub commit 9e82dce6e6bd1f36a57e08fa85af213e2b2f2622. The fix will be included in TensorFlow 2.6.0. We…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-gh6x-4whr-2qv4

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-gh6x-4whr-2qv4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-37639

Advisory: Null pointer dereference and heap OOB read in operations restoring tensors
IDs: CVE-2021-37639, GHSA-gh6x-4whr-2qv4
Record: https://patchnext.com/advisories/cve-2021-37639 (revision 3, source checked 26 Oct 2026, 13:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tensorflow 2.5.1, 2.4.3, 2.3.4; tensorflow-gpu 2.5.1, 2.4.3, 2.3.4; tensorflow-cpu 2.5.1, 2.4.3, 2.3.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI tensorflow: affected < 2.3.4; >= 2.4.0, < 2.4.3; >= 2.5.0, <= 2.5.0; fixed in 2.3.4, 2.4.3, 2.5.1
- PyPI tensorflow-gpu: affected < 2.3.4; >= 2.4.0, < 2.4.3; >= 2.5.0, <= 2.5.0; fixed in 2.3.4, 2.4.3, 2.5.1
- PyPI tensorflow-cpu: affected < 2.3.4; >= 2.4.0, < 2.4.3; >= 2.5.0, <= 2.5.0; fixed in 2.3.4, 2.4.3, 2.5.1

## Suggested inspection (read-only)
- `python -m pip show tensorflow`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show tensorflow-gpu`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show tensorflow-cpu`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tensorflow, tensorflow-gpu, tensorflow-cpu.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-gh6x-4whr-2qv4 (OSV record GHSA-gh6x-4whr-2qv4 lists affected ranges: PyPI tensorflow >=0 =2.4.0 =2.5.0 =0 =2.4.0 =2.5.0 =0 =2.4.0 =2.5.0 <2.5.1 (fixed))
- Verified: https://github.com/advisories/GHSA-gh6x-4whr-2qv4 (GitHub-reviewed advisory GHSA-gh6x-4whr-2qv4 lists affected ranges: PyPI tensorflow >=0 =2.4.0 =2.5.0 =0 =2.4.0 =2.5.0 =0 =2.4.0 =2.5.0 <=2.5.0)

Commands are suggestions: review each one before running it.

Loading voting…