Path traversal in claircore
CVE-2021-3762GHSA-mq47-6wwv-v79w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/quay/claircore 1.1.0, 0.5.5, 0.4.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.4.8>= 1.0.0, < 1.1.0>= 0.5.0, < 0.5.5
- Fixed in
- 0.4.8, 1.1.0, 0.5.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mq47-6wwv-v79w lists affected ranges: Go github.com/quay/claircore >=0 =1.0.0 =0.5.0 <0.5.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.8 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2021-3762: 4.81% estimated exploitation activity in the next 30 days; percentile 91.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A directory traversal vulnerability was found in the ClairCore engine of Clair. An attacker can exploit this by supplying a crafted container image which, when scanned by Clair, allows for arbitrary file write on the filesystem, potentially allowing for remote code execution.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-mq47-6wwv-v79w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-3762 Advisory: Path traversal in claircore IDs: CVE-2021-3762, GHSA-mq47-6wwv-v79w Record: https://patchnext.com/advisories/cve-2021-3762 (revision 1, source checked 26 Oct 2026, 14:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/quay/claircore 1.1.0, 0.5.5, 0.4.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/quay/claircore: affected < 0.4.8; >= 1.0.0, < 1.1.0; >= 0.5.0, < 0.5.5; fixed in 0.4.8, 1.1.0, 0.5.5 ## Suggested inspection (read-only) - Go github.com/quay/claircore: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/quay/claircore. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mq47-6wwv-v79w (GitHub-reviewed advisory GHSA-mq47-6wwv-v79w lists affected ranges: Go github.com/quay/claircore >=0 =1.0.0 =0.5.0 <0.5.5) Commands are suggestions: review each one before running it.
Loading voting…