Malicious password-reset in Akaunting
CVE-2021-36804GHSA-246r-r2wf-frhx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (akaunting/akaunting 2.1.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist akaunting/akaunting
- Affected
- < 2.1.13
- Fixed in
- 2.1.13
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-246r-r2wf-frhx lists affected ranges: Packagist akaunting/akaunting >=0 <2.1.13
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2021-36804: 0.96% estimated exploitation activity in the next 30 days; percentile 61.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Akaunting version 2.1.12 and earlier suffers from a password reset spoofing vulnerability, wherein an attacker can proxy password reset requests through a running Akaunting instance, if that attacker knows the target's e-mail address. This issue was fixed in version 2.1.13 of the product. Please note that this issue is ultimately caused by the defaults provided by the Laravel framework, specifically how proxy headers are handled with respect to multi-tenant implementations. In other words, while this is not technically a vulnerability in Laravel, this default configuration is very likely to lead to practically identical identical vulnerabilities in Laravel projects that implement multi-tenant applications.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-246r-r2wf-frhx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-36804 Advisory: Malicious password-reset in Akaunting IDs: CVE-2021-36804, GHSA-246r-r2wf-frhx Record: https://patchnext.com/advisories/cve-2021-36804 (revision 1, source checked 26 Oct 2026, 14:04 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: akaunting/akaunting 2.1.13. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist akaunting/akaunting: affected < 2.1.13; fixed in 2.1.13 ## Suggested inspection (read-only) - Packagist akaunting/akaunting: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on akaunting/akaunting. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-246r-r2wf-frhx (GitHub-reviewed advisory GHSA-246r-r2wf-frhx lists affected ranges: Packagist akaunting/akaunting >=0 <2.1.13) Commands are suggestions: review each one before running it.
Loading voting…