Cross-site Scripting in the femanager TYPO3 extension
CVE-2021-36787GHSA-f3rf-v9qm-9c89
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (in2code/femanager 6.3.1, 5.5.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist in2code/femanager
- Affected
- < 5.5.1>= 6.0.0, < 6.3.1
- Fixed in
- 5.5.1, 6.3.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f3rf-v9qm-9c89 lists affected ranges: Packagist in2code/femanager >=0 =6.0.0 <6.3.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2021-36787: 1.33% estimated exploitation activity in the next 30 days; percentile 71.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The extension allows by default to upload SVG files when a logged in frontend user uploads a new profile image. This may lead to Cross-Site Scripting, when the uploaded SVG image is used as is on the website. Note: If SVG uploads are required, it is recommended to use the TYPO3 extension svgsanitizer (added to TYPO3 core since versions 9.5.28, 10.4.18 and 11.3.0) to prevent upload of malicious SVG files or to set up a strict Content Security Policy for the destination folder of uploaded images.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-f3rf-v9qm-9c89
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-36787 Advisory: Cross-site Scripting in the femanager TYPO3 extension IDs: CVE-2021-36787, GHSA-f3rf-v9qm-9c89 Record: https://patchnext.com/advisories/cve-2021-36787 (revision 1, source checked 26 Oct 2026, 14:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: in2code/femanager 6.3.1, 5.5.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist in2code/femanager: affected < 5.5.1; >= 6.0.0, < 6.3.1; fixed in 5.5.1, 6.3.1 ## Suggested inspection (read-only) - Packagist in2code/femanager: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on in2code/femanager. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-f3rf-v9qm-9c89 (GitHub-reviewed advisory GHSA-f3rf-v9qm-9c89 lists affected ranges: Packagist in2code/femanager >=0 =6.0.0 <6.3.1) Commands are suggestions: review each one before running it.
Loading voting…